Google Home integration

So my Google Home devices started acting up. I would verbally tell them to turn a light on or off but the Google device would almost always reply that it can't communicate with the Hubitat. I got frustrated and removed the Google Home app from Hubitat and disconnect Hubitat from the Google Home app and tried redoing everything. Reinstalling the Google Home app to Hubitat worked fine (screenshot #1). But when I tried to add Hubitat to the Google Home app, I get the error message in screenshot #2. Now, when I tell Google to turn a light on, it will turn the light on but say "Sorry I couldn't reach the Hubitat". or "Sorry it looks like the Hubitat is unavailable right now". Any ideas?

How does your hub receive an IP address? Via DHCP? Or via a static IP address configured at the hub itself? If it is the latter, configure the DNS servers to be,, Then reboot the hub.

I'm not very good with this end of things. Can you explain how to find the answer to your question?

To check if you're configured for DHCP (FYI if you don't know you probably are but it's good to check).

1 Like

I am connected via DHCP. Should I change anything? And why does it say WiFi is not detected?

If you don't have a wifi dongle the C7 will not detect wifi.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.