Google home hub(s) no longer speaking or playing audio

I have a few of these around the house. Lately they have not been playing or speaking anything. When mail arrives, I have it speak on these speakers "mail has arrived". I also have the speakers announce when its almost time for the kids to go to bed. Lately, and I have been trying this today, I am trying to send any text speech to the devices. I send a speech to it that clearly says "this is a test", and all is heard on the speaker is "Tssssss"... a brief second. Or should I say it says "tiss". Just a sound effect rather.

I also uploaded a file that says "you've got mail" to the hub and tried to play it directly on the rule or on the device page, and that still doesn't work.

When there is an entry in the log, it says this:
2021-12-17 10:29:25.512 am [error]org.codehaus.groovy.runtime.InvokerInvocationException: su.litvak.chromecast.api.v2.ChromeCastException: Unable to load media (method playTrack)

Anyone else having issues?

Go to the speaker in devices and click initialize and see if it works after that. I've see if you don't set a reservation for google speakers, sometimes they're lost until you reinitialize. Just a thought.

Unfortunately that did not work. Sometimes when I try to play a track from it, it just dings (like it is about to play something) and then does nothing.

@gopher.ny Any advice?

If you don't use the file and simply put something in the notification field does it work correctly?

no it does not. At the very least it does the brief sound effect of "Tiss".

Are you using the built in or community integration?

I believe built in... its the Chromecast integration (beta).

1 Like

Yeah I'm out of ideas. Gotta wait for @gopher.ny to chime in

1 Like

Could you please PM me your hub's id? I'll take a look at the engineering logs on the hub.

2 Likes

I'm seeing a similar issue on at my four Google Home/Nest Hub Mini devices. Whenever something tries to Speak at them, they start spitting messages like this in the logs:

su.litvak.chromecast.api.v2.ChromeCastException: Unable to load media on line 240 (method runQ)

Any time the IP address for a Google Speaker changes, it will likely break.

Makes sure the IP addresses are correct.

All my devices have fixed DHCP assignments, still they will never change. I did verify that Google Home and Hubitat agree.

2 Likes

I figured it out. I had the UI set for SSL only. Sounds like a bug in the Chromecast App. When I disable that, Speaking on the Chromecast devices works again and I don't have those messages in the logs.

Where do you see this? How do I make this change?

You can find the details in this thread:

Wanted to give a little update to this issue. It is now working. Not sure what exactly did it though. All I did was the following:

Update the hub firmware to the latest version.
Added a delay of 1 second to the device "Delay before speaking, seconds" setting.

Brining this back lol. Where did you set the SSL?

Download the Hubitat app