Google Home and Amazon Alexa both see my fan switch as a light

I am using a GE Z-Wave Smart Fan Control (3 Speed) and originally had it connected to Google and Amazon assistants with Wink and then Smart Things. Now I have it setup through Hubitat, but now both Google and Amazon see it as a light switch. So now, when I ask Alexa to turn on the lights in the room, the fan comes on too. Is there any easy way to fix this?

What driver are you using. My GE Z-wave fan control shows up as a Fan in Alexa. I am using the GE Smart Fan control driver.

My Hubitat settings are as follows:

Device Information:
Device Name - GE Smart Fan Control
Type - GE Smart Fan Control
HUB Mesh Enabled - OFF

Controller Type - ZWV
Data: Device Type - 18756
Data: Manufacturer - 99

All of that is exactly the same as mine. I have several, I looked at two of them, one on my C7 and another on my C5. They both appear as Fans in the Alexa app,

Perhaps you should remove them from the Amazon Echo Skill and add them back

I don't have this fan switch, so I can't help you with what it acts like with either of these apps.

But I wonder if @terminal3 this setting is the same for both you and @ksorensen? And ksorensen, it wouldn't hurt to toggle this and see if it makes any difference.

I do actually have that set, I wouldn't think that would effect how the device is recognized but maybe so.

For Google Home, use this for your devices: [Alpha] Community-maintained Google Home integration

All my fans show up as fans in the Google infrastructure.

The Alexa app allows you to designate what type of device each object is, such as which object is a light and which is a switch, regardless of what HE thinks it is. Solved same issue for me. Handy feature!

Yes but it should be listed as a fan not a switch or a light.

In the Alexa app, I see that only certain devices can change type. I can change a plug to a light; however, I cannot change a light switch to a fan controller.