Google Assistant Routine Error

I have different modes that trigger my alarms to go on or off. When I trigger a mode through a routine in google assistant, it gives me the following error after the routine is executed. The routine is to change the mode to night mode, which executes successfully.

"Sorry there was an error for the Night mode"

Any ideas on how to troubleshoot this error.


Experiencing the same.

How are you inputing into your google routine to change the mode on hubitat? Can you show a screenshot of your Google Assistant routine?


Please see attached. Night mode switches the Hubitat Safety Montor to Night Mode and arms the system. The Goole Assistant Hubitat app makes the different scenes / modes visible on Google Assistant. The google assistant scene is triggered through GA on google mini or any other GA device like a phone. It seems now that the scene is executed correctly and it switches to Night Mode however it always still gives the error. This error is through any GA device


Okay....You did not show the setup of the Google Assistant Routine. That is the one thing that I asked for. It should look something like this:

Here you go. The setting just changes the scene to enable night mode.

There is a outage in the US.

Well, #1, I am not having any trouble controlling my Hubitat devices with Google Home right now. And #2, I don't think they have ever worked correctly from Google Home. What I would do instead is use a virtual switch. You can set up the switch to activate night mode by Rule Machine. You can that set that routine to turn off the virtual switch. You can then have the virtual switch turn itself off after so many seconds. I know it's a longer workaround but there has been a report about that as a known issue with the google integration.

Just to clarify though...the problem is on the feedback to Google will set the mode the way that you have requested.

Everything seems to work Lights etc. Its only when I set the scene to night mode that this error message appears. Again it does change it to night mode despite the error.

Perhaps Ill open a support call.


This has been a known issue for quite some time but you're welcome to raise the issue via Like I said, using the virtual switch is a way to eliminate this problem.

And has nothing to do with the Google services being down. Search for Google and Mode here on the forum and you'll see a half dozen posts at least about the same error going back months. And, as you note, the action does take place on Hubitat, just the error is also posted. So, the action is clearly happening. Otherwise the mode wouldn't change.

This worked great. I setup the virtual switch to turn itself off after the mode changes. A timer may be a better idea so I don't get stuck in a loop but tests have gone well.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.