Go Control Stopped Reporting Operating State

So, I have a problem with my go-control thermostat. It stops reporting changes in status to the hub or the hub is not accepting them. I tried excluding and re-adding the damn thing and it worked the first sequence of the AC but now it is not working again. Has anyone ever experienced something similar?

I am able to press refresh several times to foce it to update.

Did you ever get this figured out?

Do you recommend the Go Control Thermostat?

I did. I ended up excluding and then rejoining the go-control to my hub and it worked perfectly. This is the first non-Wifi thermostat that I bought and I got it on the recommendation of someone else here on the forum. The reason I picked this one is I was able to find it really cheap on ebay and having just lost a bunch of money on an ecobee that I had for 6 months (hated that thing) I didn't want to spend a lot. It works great. No complaints so far. But it's not very pretty to look at. But then again, it is just a thermostat. lol

Why can’t they make a decent looking Z-Wave or Zigbee thermostat?!

I’m actually thinking of going with either Nest or Ecobee based on appearance! Is that crazy or what?

They make one that's absolutely beautiful. I just don't want to fork over the $140 for it at the moment.