Global string and dashboard stuck “sending”

Hi all

I have another dashboard related problem. I’ve previously logged on the forums of the dashboard stuck in a “sending” status. I’ve now been able to trigger the same problem when using a GV with a connector. This has only started happening when the C7 firmware patch was released a few weeks back. I initially thought it was something to do with a Nanoleaf driver but now I’m not so sure.

Anyone else having the same problem ?

I have a Zooz Zen30 where the Fan switch sticks on sending on the dashboard but so far that’s the only one I’m seeing.

It appears after a dashboard refresh the correct value is set. Is it the same for you ?

I click to turn the fan on and the fan comes on but the icon sticks. I can click on it again and the fan will turn off but the icon will not refresh without a page refresh. And with the fan running it never shows the switch in an ON state even after a refresh. This is on a C7 and it was that way on as well as I'm pretty sure it worked prior but I can't be 100% sure.


Ok just found something very strange. Can you try this

  1. Click the gear icon on the dashboard
  2. Select advanced
  3. Debug and select enable. When on I can’t get it stick on sending. But when off I can !
1 Like

Interesting. I’ve seen this happening sporadically, but I usually look at the dashboards while coding something for them. I’d clear the cache - because some underlying code was changing - and things would just work. I’ll keep an eye out in case the issue could be reliably reproduced.

1 Like

@gopher.ny I can 100% reproduce the problem. When debug is disabled it will happen typically after 2 / 3 updates.

I initially thought it was a problem with a nano leaf driver update but that doesn’t appear to be the case however I have been able to work around that issue.

For me that log shows:

8/31/2020, 3:17:03 PM - Debug Log Started
8/31/2020, 3:17:08 PM - Sending Command on to id 265
8/31/2020, 3:17:09 PM - Command Sent
8/31/2020, 3:17:12 PM - Sending Command off to id 265
8/31/2020, 3:17:13 PM - Command Sent

The first was to turn it on and the second to turn it off.

Did it get stuck on sending with the debug on ?


Ah okay.

Another question if you change the device on / off from the device section will it work reliably ?

Yes it turns on and off from the device page and the dashboard just fine it's just that the icon will never update to an ON state. If it's off and you click it you get BUSY and the fan comes on. If you refresh the dashboard at that point the icon will show OFF but it is still running. I'm sure someone else will report this eventually and they will work it out. As long as it works I guess it's not a huge deal but it would be nice to have the correct icon displaying.

Sounds like you have the other problem I’m having with a Nano leaf, I screen captured my work around using a virtual switch and rules machine.

Has worked 100%, keep both the real and virtual switch on the dashboard and only use the virtual switch for changing the on / off state for me the real device follows the status perfectly.

Right I used a virtual for a test and it does update. I just hate to clutter up my devices with virtuals that should not be needed.

I'm just hoping @bcopeland will respond at some point to this post or my one from the weekend. I'm just curious if it's a known issue with a fix coming or what.

sounds like we have the same problem but with different devices.

I really think something strange is happening on the dashboard. My C5 device is holding an older os release and everything works perfectly, the C7 with the latest os and previous version have the problem.

I'm seeing some things stuck "sending"--and going into the device itself and doing a "refresh" causes it to clear up.

Seems some packets may be hitting the bit bucket.

1 Like

I was curious the last update on this topic. I am having the issue as well as of today. Any solutions?