Gledopto Zigbee 3.0 led controller no pairing

Good morning community.
I am really new with connected devices and the HE.
I bought HE because I read so many nice reviews about flawless network and advanced systems.
I am confronting reality though as nothing seems to work. I have had HE for 1 month now. I tried to pair several Zigbee devices with NO success so ever.
So I decided to buy a device that it's recommend either on this forum or it appears in the HE list.
So I bought the gledopto Zigbee 3.0 led controller and was saying to myself that this time it would be fine.

I did as asked. 5 times on off/ factory reset several times but NO pairing at all. I tried all methods of pairing (with no repeaters with clear keys etc) but nothing is discovered.

Is there a specific method we use to pair ? Is it really so difficult ? I wanted to avoir home assistant and use sth more automatic but I get really disappointed and I am asking for your help out there hoping to find a solution.

Thank you so much I'm advance for your help :pray:
All the best

Hello Yannis and welcome to Hubitat community forum!

If not done yet, join the Hub owners - Hubitat group so that you are allowed to post screenshots in the forum.

If you go to Settings -> Zigbee details, do you see Zigbee interface enabled and the PAN Ids populated? Have you also tried changing the Zigbee channel (in a case you have strong WiFi interferences)?

What other Zigbee devices you have tried to pair to your HE hub (I suppose it is a C-8 model)?
Can you confirm that when you try to pair a Zigbee device, it is put in a pairing mode - usually, by pressing the pair button for 5 or more seconds. Most of the devices will confirm the pairing mode with a LED flashing.

Also, try the pairing close to the HE hub.

1 Like

Hi Kossev and thanks so much for your quick reply :pray::pray:
Just joined the owners.
I have a C8 HE yes.
I am trying to pair in 2 meters distance from the HE.

Just checked the Zigbee details
It is enabled and about the pan and the channel I attach two screenshots (thanks for the advice :slight_smile: )

I have not tried to change the Zigbee channel. Could you please tell me how to change it and to what channel I have to change it ?

I have tried to pair a sonoff Zigbee controller and Profalux Zigbee screens and stores.

And yes I switch off on 5 times until the led lights flash 4 times.

Thank you so much again for your help. Hope that it is a software adjustment that I might have not yet adjusted or sth.

All the best

You can change the channel from the control circled in green, but most probably this is not the problem at the moment (except you have the C-8 antenna put very close to your WiFi router).


However, it is really strange that you have one Zigbee device which is shown crossed out (circled in red). I don't know what does it mean, hopefully someone will chime in and give some more ideas.

If you click on the 'Scan channels' hyperlink, do you see any Zigbee channels in the table that will open on a new tab in the browser?


Thanks again for your reply again @kkossev :pray:
The router and the hub are in the same rack. I send you a pic to see they are really close.

I send another screenshot for what you ask

As for the deleted device I do not have any idea what it is. I see that I have two devices on the hub, but the only thing that I managed to connect was to connect Alexa with the hub, so every time I pair sth to the hub it will be automatically added to the Alexa network.
Maybe it's that one ?
I send another screenshot with my two devices on the hub.

One should be my mobile ? And the other Alexa ? I don't know I have never paired anything.

Thanks again for your help :pray:

All the best

Give this a try ..

You Need to check your WIFI settings and zigbee channel.
Setup your WIFI system to channel ( 1 ) on all routers and AP's and reboot router and AP's.

Make sure / setup hub ZigBee to channel 20 with 8-12 power.
power off the hub .. using the GUI - Settings / shut down for 3-15 min
Move HUB away from router / ap's using a cat5 cable

once you have all that setup .. power up hub.

Delete that device ( device )

Now try and add the device you want to the system / make sure you factory default it.

1 Like

That is a pretty terrible location for a hub. You have it in a metal cage, and there is tons of interfering equipment surrounding it. I would be surprised if you could pair any device with it, or keep devices on the mesh IF they even pair.


Thanks so much for the replies @WarlockWeary & @neonturbo :pray:
I did exactly what you told me and I COULD FINALLY PAIR IT !!!
Thank you so much!

Now I am trying to see the interface of the device. I see that i cannot change the colour of the leds. I tried to change the colour map settings and after i clicked save presets. But nothing changed.
Is there another workaround to change the led colour ? I tried as well to change by numbers the hue, level, saturation etc. But each time that i click save presets, i see that nothing has changed. Everything remains like shown below

Current States

  • colorMode : RGB
  • colorName : Blue
  • colorTemperature : 6329
  • hue : 67
  • level : 20
  • saturation : 100
  • switch : on

I tried as well to switch it on and off but nothing happend

Only the off or on was greyed when i clicked in each one but it did not switch on or off.

Thanks again enormously for your help. I see hope again :slight_smile:

1 Like

As the problem was probably not the gledopto but my hub's adjustments, I would like to share with you that I just paired another device that could not pair before
It is this one

But same thing. I cannot find the adjustment control. This switch is supposed to switch on and off a wall plug and controls the consumption of electricity. But I do not see anything relative. Not even a switch on/off button.

Is there sth that I do not do correctly ?

Thanks again so much :pray::pray::pray:

You may want to start a new thread on this .. sorry I do not know enough to help.
other then you can try a different driver .. just remember if you try a different driver you always have to press the configure button!

I did find this : [RELEASE] GLEDOPTO ZigBee RGB+CCT Controller GL-C-008 2ID Driver

No Idea if it world work :confused:

1 Like

Thanks so much for your reply and help @WarlockWeary :pray:
I will check it.
By configure button could you please tell me what you mean ? I tried to find more info about this on net but it is not clear to me. Is it a button that I have to create in the interface ?
thanks again enormously!!

^^^^^^^^ this button ..

^^^^^^^^^^^^ TYPE = Driver you want

Ok I see
the ting is that when I click on configure, nothing happends
as the rest of the buttons in the device.

I will make another thread yes.
Thanks so much for your kind help :slight_smile :slight_smile:

It may or may not .. when you click configure .. it tells hub to use what ever driver you picked ..

ok thanks so much