Ghosted on ghost issue. How do I create/submit a support ticket?

It wasn't Alexa Hunches as I turned those off and it just did it again (i.e. turned on all devices in my den).

What does it show in the events tab on one of the devices?

Sorry to have been away so long. I was able to get one problem fixed, and that was my room turning everything on. I was able to track that down to an Alexa routine that was turning it all on at Sunset. I'm the only who ever does any automations and I'm 100% I didn't intentionally create it. I don't know if it was an Alexa hunch or suggestion and I said OK to it or what. But, in any event, that's resolved.

So today (Feb 4, 2024) I wanted to try to resolve the issue where I have a device with a route, but no name. That was 4B a/k/a 75.

My plan was to follow these steps:

OK, since you have PC Controller and since the device appears to be a switch based off your screenshot, go to the Network Management tab, select device 75, then click "Basic Set ON" and then go around your house looking for the switch or light that just turned on.

You can alternately hit the ON and OFF commands to help you locate the device. This will help you identify WHAT device is device 75.

Then, in Hubitat, create a virtual device, but select the appropriate type for that device, ie "Generic ZWave Switch", or whatever is appropriate.

Create the device, then change the network ID. You'll have to tell Hubitat that you think you know what you're doing. Then you'll enter "4B" in the ID box (without the quotes. 4B represents 75 if hex).

After you do this, save the device, then immediately hit initialize or configure at the top of the device page. It should sync Hubitat with the switch and you should be golden.

The first issue I have is that controller appeared as 129 and 131. 129 is in Hubitat, but not 131

But in the PC Controller it looks like 129 isn't working, but 131 is.
Screen Shot 2024-02-04 at 3.12.27 PM

I don't know if that is the reason, but for whatever reason, with 75 selected clicik on Basic Set On did nothing:

The next step said " You can alternately hit the ON and OFF commands to help you locate the device." But I don't know what that means as there are no buttons that say just "ON" or "OFF", Just the Basic Set On and Basic Set Off. So I couldn't try that as I couldn't find any such button.

I then started looking on my Hubitat Devices page and noticed one was missing, my Master Bathroom Toilet Fan. This device is an Inovelli Black On/Off. Since I have others just like it I went into one and saw the Device was an Inovelli Switch LZW30.

So I created a virtual device with that driver and made the ID 4B. (I added "AA AA" to the name so it would sort to the top.

I saved it and then quickly press the Configure button (as I didn't see one called "Initalize")

I saw this in the logs after I pressed Configure:

I then went to the Devices page and 4B is now my virtual device:

When I'm inside the virtual device in Hubitat pushing the On or Off button does not generate anything in the logs and the Current States remains blank.

As a test I changed the drive to Generic Z-Wave Plus Switch:

And since there is no Initialize button I immediately pressed the Configure button again.

But as you can see above, I still have nothing under the Current States and it doesn't show up in the logs at all. BTW, I did create a virtual device a long time ago to act as a place holder for my Inovelli Red Series dimmers for times when I would have to take a device offline and didn't want to re-do apps. Pressing the on/off button for that does change the Current States and shows up in the logs. So this vitrual device isn't working.

So I am not "golden". Hubitat still doesn't know that is the Master Bathroom Toilet fan.

So what do I do now?

You probably just need to remove that node 0x4B and pair that device again.

1 Like

What is the best way to remove it?

You can try doing a normal exclusion on the device first. If the device is still attached to that hub node it should take it out with the exclusion.
If that does not work you can try refresh/remove from the hub, and last resort would be using PC Controller. This has instructions for the hub removal method and PC Controller: How To: Remove Z-Wave Ghosts (including using a UZB Stick)

I am trying to follow the instructions on how to have Hubitat remove a ghost. I'm not 100% sure if it is considered a ghost as it has a path, but no device.

I'm 99% sure which device it is and pulled the air gap. I then clicked the refresh button. As you see it says "Pending". I was read the part that said I should be patient and not push it again too fast. I've waited 2 hours 50 and it still says Pending. So I don't think the screen has refreshed yet. How long should I wait? Can I press Remove now?

As this is my bathroom fan I can't leave the air gap pulled indefinitely.

BTW, I have a 2nd one the is a classic ghost. However, I have no idea what device it is. So I had tried turning off every device and using the PC Stick but that didn't work.

I don't want to click the Refresh, Remove or Discover buttons until the Pending is cleared from the other one. Or is it OK to click one of those now? If so, which should I click?

They both have neighbors listed, the hub will never be able to remove it unless the only neighbor is the hub itself. Some sort of bug (or feature?) with the z-wave SDK.

Probably only way to get rid of them will be a USB stick.

Why not? Error? Or what happened? I have never had this NOT work.

Nothing happened. I threw the breakers to all of my devices at once and unplugged all of my smart plugs and using the PC Stick did nothing as detailed above.

That's totally unnecessary, especially using the USB stick.

I would exclude the stick then reset it and include it fresh. Then try again. Make sure you are on the correct node using the dec number from within the ( ) in the z-wave details page on the hub (not the hex 0x number).

What step does "nothing" happen? There are multiple steps, is the fail check working? It should be telling you something in the status bar, it also has logs you can open. "Nothing happened" is not helpful, its doing something...


I ended up with a Ghost PC stick as you'll see below:

How do I exclude them?

Should I take the USB out of the computer first?

Unplug the stick from your computer.

Shut down your hub, at the red LED pull power, wait 30 seconds, restore power and let it boot up.

Go to Z-Wave details, hit Refresh for the ghost UZB stick. The Remove button should appear, hit that.


I followed these steps:

Unplug the stick from your computer.
Shut down your hub, at the red LED pull power, wait 30 seconds, restore power and let it boot up.
Go to Z-Wave details, hit Refresh for the ghost UZB stick. The Remove button should appear, hit that.

And was able to ger rid of the ghost PC Controller. So now all I have is the "good" one.

At this point the PC Stick is not plugged in.

Please give me step-by-step instructions on how to proceed from here. (Do I have to remove/exclude the "good" one, can I just plug the PC Stick back in and then run the SI software, etc.?)


You can leave it in your Z-Wave details page...nothing should route through it (I never saw anything try to route though my UZB stick when I left it in my Z-Wave Details), so it shouldn't cause any problems, and should be there if you need it again.

If you want to remove it normally, the instructions are in the Ghost Removal PDF in my topic.

So I plugged the PC Stick back in and started up the Silicon Labs software. After it did an update and I logged in I got these 2 windows.

What do I do now?

Depends on what you are trying to do...

The full instructions for using the UZB stick w/ghosts are in the PDF download available in this topic:

Click Tools then open PC Controller. Same as you did before to get into it.

From there you can exclude the stick from your hub if thats what you are trying to do (I assume instructions are in that guide as indicated).

Otherwise you can just leave it plugged in (no need for the software) and it will act as a repeater. Mine is near the center of my house and does repeat sometimes. I just leave it plugged in all the time.

I got to Network Management per the instructions and I can see my devices.

Since I can see the devices I then went to step 15 that says:

15.Exclude your Ghost: IMPORTANT: Make sure you remove power from the device that caused the ghost which is almost always the next device in the Z-Wave Details screen in HE. Flip a circuit breaker, pull air gap on a wall switch, remove batteries, etc. The ghost device must not have power.

a. Find and click on your "ghost" device. In the picture above, device 21 is the ghost device.

b. Click on Is Failed in the upper right pane-hopefully it will mark the device as failed. You’ll know the ghost device has been marked failed when the name of the ghost device text turns redlike this.

c .Then click on Remove Failed

d. If the ghost is not removed, try clicking on NOP and maybe Is Failed again a few times to see if that works to get it into Is Failed status

Here is my ghost device # 86 so I air gapped # 87

As you see, it worked in PC Controller and removed #86

Screen Shot 2024-03-04 at 5.58.49 PM

However, I still couldn't remove it from Hubitati.

So 15 goes on to say:
NOTE: Not commonly, but in some cases when removing a ghost, the ghost will disappear from PC Controller but persist on your hub. This can occur if the UZB stick is not connected to your hub’s mesh while removing a ghost in PC Controller. The ghost is removed from the UZB stick’s mesh but isn’t removed from your hub. In that case try the following:

  1. Exclude the UZB stick from your hub

  2. Reset it, if it has a reset option

  3. Re-pair the UZB stick to your hub

  4. Remove the ghost node again in the PC Controller app

I was able to exclude the PC Controller from Hubitat by using the Discover and Remove method.

I then put Hubitat into Include Mode and plugged in the PC Stick but it wasn't found. I can't find the instructions on how to include it again.

I have the Zooz 800LR Z-Wave Stick ZST39 LR. I don't see anything in the instructions on how to put it into inclusion mode. (Which is why I thought all I had to do is plug it in and put HE into inclusion mode).

BTW the Zooz instructions say The 800 Series Stick can only be reset by the host software while it's in SerialAPI mode. The device is reset once an appropriate command from the host software is sent to reset the Z-Wave network. There is no way to manually reset the S2 stick if it's not controlled by host software. So I have no idea what that really means or how to do a Factory Reset if that is needed to re-pair it to Hubitat.

I'm hoping that isn't the case, but can you point me to the instructions on how to paid the Z-Wave stick to Hubitat?

BTW, am I correct that there is no Add Device from the Z-Wave Details page, just to Exclude one? If so, I'd like to add that to the Wish List.

Instructions to include the UZB stick to Hubitat are at the beginning of the instructions.

Anything specific to the Zooz stick is beyond my pay grade, I have never seen/used one, sorry.

Sometimes it can take multiple tries to include a UZB stick to HE, so I would start by:

  1. Hub: Shut down/pull power/wait 30s/restore power
  2. Try the UZB stick inclusion process from the instructions several more times to see if it will join

@jtp10181 may have some additional wisdom on this.

Thats a lot of words.
What is the issue exactly? I think just trying to reset the USB stick?
There is a "RESET" button right in PC Controller, that will reset any stick I have ever worked with.

Once reset the guide has inclusion instructions, the stick does not enter inclusion mode just by plugging it in.