Getting Yale Zigbee Lock to work with Mobile

Hey everyone, I'm trying to figure out a way to get my Yale Zigbee Lock YRD226 TSDB to work with either the Mobile App, or integrate with my Google Home Controls, because right now it wont show up with either. I can get it to work with scenes and automations within HE, but I cant get it to show up anywhere mobile to lock it from outside my home.

I was able to add mine to a dashboard and works just fine using the web interface (local) or app (remote).

Can you access & control it locally on a dashboard?

Did you go to the Apps tab, go to Hubitat Dashboard app, and then add this lock to the desired dashboard?

Items do not automatically get added to dashboards, you have to select what items are authorized to be on a particular dashboard.

I have added it to a dashboard, but I can't seem to connect to a dashboard unless my phone is on the local network.

Under the APPS tab, under the Dashboard app, click on the child dashboard app that you created, then click Advanced

and make sure that access is turned on for Remote / Cloud

1 Like

Iv checked this and i have it selected already. I am having this issue because i dont have a remote admin subscription?

I can access it locally on a dashboard, just not remotely

Remote dashboards don't require a subscription... only remote access to the hub UI itself.

Don’t need a Remote Admin subscription to run dashboards, the hub will need to be able to access the internet however.

In your browser let's try entering

http://yourHubIP/hub/networkTest/ping/1.1.1.1
1 Like

Ok I tried that but, it doesnt seem to work. on a side note, i can connect to the dashboard via the phone browser from the cloud dashboard link in the app settings of the dashboard, but i cant connect via the mobile app.

Not sure what you mean by didn't work. Should return something like

PING 1.1.1.1 (1.1.1.1) 1250(1278) bytes of data. 1258 bytes from 1.1.1.1: 
icmp_seq=1 ttl=53 time=27.2 ms 1258 bytes from 1.1.1.1:
 icmp_seq=2 ttl=53 time=26.4 ms 1258 bytes from 1.1.1.1: 
icmp_seq=3 ttl=53 time=25.2 ms 1258 bytes from 1.1.1.1: 
icmp_seq=4 ttl=53 time=25.3 ms 1258 bytes from 1.1.1.1: 
icmp_seq=5 ttl=53 time=28.5 ms --- 1.1.1.1 
ping statistics --- 5 packets transmitted, 5 received, 0% packet loss, time 4006ms rtt min/avg/max/mdev = 25.211/26.532/28.477/1.224 ms

assuming you put your hub's IP where indicated

ok it worked this time

PING 1.1.1.1 (1.1.1.1) 1250(1278) bytes of data. 1258 bytes from 1.1.1.1: icmp_seq=1 ttl=58 time=15.2 ms 1258 bytes from 1.1.1.1: icmp_seq=2 ttl=58 time=20.5 ms 1258 bytes from 1.1.1.1: icmp_seq=3 ttl=58 time=20.8 ms 1258 bytes from 1.1.1.1: icmp_seq=4 ttl=58 time=15.2 ms 1258 bytes from 1.1.1.1: icmp_seq=5 ttl=58 time=14.5 ms --- 1.1.1.1 ping statistics --- 5 packets transmitted, 5 received, 0% packet loss, time 4007ms rtt min/avg/max/mdev = 14.533/17.236/20.787/2.806 ms

Okay. Hub is getting out. Just saw that you added that the phone browser can get to the cloud dashboard, but not the mobile app => thus issue is not the hub. Are you running the iOS or Android version of the app?

@bobbyD

2 Likes

Android version

Could force the app to using the cloud link by entering the it as a Custom Dashboard but then it would always use the cloud. Might be worth a try temporarily for testing, but not the solution.

Edit: if you switch off the WiFi on your phone does the app display a cloud in the upper right corner?

I put in the url for the custom dashboard for now.

and no it just doesnt seem to work when i switch off my wifi

Sounds like the mobile app isn't seeing the network change. I might be tempted to delete the app, and reinstall...

Download the Hubitat app