Getting Thermostat Scheduler to turn Thermostat mode to OFF when Away or Disabled

I am struggling to understand just how the Restrictions work with Thermostat Scheduler. Specifically, I would like to turn the Thermostat OFF when I select Away mode.

I was thinking that if I set the Thermostat Scheduler Restrictions to "Only when mode is Day, Evening, Night" and selected the "Turn thermostats OFF when restricted" switch that it would turn the Thermostat OFF when the mode was Away. Apparently, I am missing something here because that doesn't happen. The Thermostat Scheduler's Restricted status does not follow the Away mode, i.e., show as Restricted when Away but not when Day, Evening or Night. Is there a trick to have the Thermostat mode transition to OFF when Away and back ON as scheduled when Day, Evening or Night?

This works for me. Show your Thermostat Scheduler setup page. Mine looks like this:

Also, look at the Event Subscriptions on the App Status page. There should be an entry with Event "mode", and Handler "refresh". Also, turn on logging in the app. When the mode changes to one of the restricted modes (i.e., one not selected in 'Only When Mode Is' restriction setting), there should be a log entries like this (my restricted mode is called "test mode"):

With the settings shown above, this also works for Away mode -- that is, the thermostat mode is changed to 'off' when mode becomes Away, and back to its scheduled setting when mode becomes one the selected modes.

For Restrictions, 'Only when mode is' means not restricted in those modes.

@bravenel, I have pretty much what you have. Here is the Thermostat Scheduler setup:

Here are the Restrictions:

Here are the Event Subscriptions where you will see the "mode" but not the "refresh" you expect:

And, here is the log from the time I selected a transition from Day to Away.

Thermostat Scheduler Logs

Perhaps you can confirm from the Event Subscriptions and Logs, but what I observe now is that the Thermostat Scheduler is always showing as Restricted. About a minute after transitioning from Day to Away at 06:30, I returned to Day. But, as you see, nothing changed in the logs and the Restriction persists.

I might suspect that the App was corrupted, but I find a similar issue on two other HE systems that I manage. Any thoughts on what I should do to further unearth the issue?

Hit Update in the app, and then look at the event subscriptions again. If still no refresh there then something is corrupted for sure. Are you on platform release

The refresh method performs the thermostat mode to off and back to the setting upon mode change, so without that event subscription, it can't possibly work.

If hitting Update doesn't fix it, then you have no choice but to remove that instance of the app and create it again from scratch. I've checked multiple instances of Thermostat Scheduler, and they all behave in this regard.

@bravenel, Well, deleting and re-creating App solved the problem. It now shows the "refresh".

FWIW, these two errors showed up (before I deleted and re-created) when I selected "Update" and followed a few seconds later with "Done" in the Thermostat Scheduler App. Maybe they offer a clue as to what got corrupted?

Bottom line, issue resolved. Will perform the same action on my other two HE sites and hope for same results. Thanks for the guidance.

@bravenel, I've deleted the Thermostat Scheduler App and re-created it for my other two remote-administered systems. Both of them now work as expected, setting the Thermostat OFF when transitioned to Away and back ON when returned from Away. Perhaps the problem came about with an update and I just didn't notice it. FYI -- now running In any event, great news. Thanks.