Geofencing should be in settings page

I don't know if there's usage that I don't know of and requires the Geofence page to be at hand quickly? It seems to me something that we set once and forget. In fact I already changed my geolocation inadvertently thinking that I shall have to "apply change" before it takes effect.

I plan on installing the app on other family members phones and I'd prefer to not have to teach them all "this is the don't touch page".

2 Likes

Geofencing in the app will allow your hub to know if you are present or not within it - if allowed, the phone app will send an “Arrived” or “Departed” event as applicable. This can be useful for some automation and to set the mode to “Away” if everyone is actually away. If you don’t use that, then there is no need to set it.

Thanks for your reply @Sebastien. I'll clarify my point. I just want to say that this button have no reason to be on the main app page. It's a set and forget that should be accessible only in the settings.

3 Likes

Hi, it's only set & forget until the app makes you login when you're not at home. For some strange reason it changes your home location to where ever you are when you log back in.
Very inconvenient when you're not at home, you login in a remote part of the country with very little internet, your phone then tells the hub you're at home,so you're alarm disarms & your garage door opens.
This has been a problem for ever that no one seems to want do anything about it

1 Like

Yeah that's it! Now that you explain it, exactly what I experienced.

Ouch! @moncho1138, is that intentional?

Yeah, intentional but not in that way, the app is set to forget geofence location on logout, but it shouldn't replace it when credentials are expired.

Definitely a bug to look into.

2 Likes

This is why I use HomeKit for my presence. An automation in HomeKit sets a virtual switch and a rule in HE uses that switch to change phone presence. HomeKit geofence works flawlessly enough that I disabled HE’s geofence. I also tried doing something similar in Alexa as a backup but it was less reliable. There are multiple threads on the forum about all kinds of creative workarounds for presence using WiFi, Life360, and other 3rd party tools but I personally am very happy with the HomeKit hack. This only works with the Homebridge + tonesto7 version since the new HE native HomeKit doesn’t support virtual switches due to an Apple certification requirement.

I use "Combined Presence" with switches set in various ways. Currently I'm using Alexa, my iPhone, and HomeKit, along with GeoFency for good measure. It's been pretty solid. I admit the HomeKit one usually triggers first.

Geofencing is an essential service, it should be "reliable." Hubitat geofencing It is not, which is why most of us seek and use alternatives.

Update on my last post, this time I didn't login again, I waited until the app logged in again when the internet connection was faster & it did. Therefore the geofence location remained as it was.
The location of your phone has nothing to do with your home location which is why I can't see why this problem hasn't been fixed

Geofence/presence seems to be completely non functional/broken in the latest iOS app 1.8.2. I’ve posted regarding this and tagged support but no one has bothered to respond which is very disappointing.

1 Like

The fact that it is problematic on iOS is generally considered old news I’m afraid. Geofencing and presence are dependent on several variables some are controlled by the user, but most are controlled by the manufacturer of the phone. Apple seems to be particulary determined to make it hard for any app outside of its own to provide a usable location, and more than once has broken its own APIs to keep it that way.

A couple of things that sometimes help:

  1. Make sure that Location Services are on
  2. Make sure that the Hubitat App has
    a) Location Services set to always
    b) Background App Refresh set to on
    c) Celluar Data set to on
    d) Allow Notifications set to on
    e) Motion & Fitness Tracking set to on
  3. Turn off Private IP address for your local network

Fair enough. It just seems strange that the issue we're having coincides precisely with the app update. I had checked most of the settings above. The only difference was that I had Private Ip enabled which I've now switched off. I doubt it will make a difference in this case but I'll post back if it does. Thanks.

My wife & I have Galaxy 10 & 21's. It seems that after most firmware updates the geofencing mucks up for a while. Then it goes back to being reliable again. So a few years ago I also started using 'Combined Presence' using Life360, Hubitat & Wifi Presence.
I've just started testing Google Home's presence. It works although I haven't found a way to adjust the area it uses.

Download the Hubitat app