Geofence suddenly started working?

Is it just me or did geofebce in the app suddenly start working correctly today?, today was the first time I've ever seen it give me - (correct) notifications of leaving and everything the geofence.

There was an app update recently (past week or so), and I seem to remember it mentioning geofence fixes. Maybe that was it?

Oh wow I had given up on it. Will have to re-enable and see if it gets any better.

Must have been the update. Yesterday I started getting notifications about entering and leaving the geofence. I had given up on it a while a go. I guess I just hadn't noticed the update. I'll have to start testing it out to see how well it's working.

Yeeh I gave up a long time ago myself. I've been looking for other options. I'm still sceptical, but I'll give it a try.

I use that and life360... neither are 100% but the two of them together (if geofency is really working again) are close!

A long time ago I could never get the geofence in the app to work reliably. I never shut it off, just didn't use it. I also use life 360. It was having its own issues, but seems to have gotten better. I've been lookin at some of the aggregating apps.im also trying to use tasker and fing (if I can figure out how to connect it).

I use Joel Wetzel's combiner app. Works well.

2 Likes

Well it worked for a few days, then stopped working for a few days, then started working again today. While it wasn't working I was getting this in the debug log every few hours

I am finally seeing the geofence appear on my map, but it doesn't seem to be able to tell whether I'm inside or outside of it.

Does it matter if I have location permissions turned off for most of the Google products on my phone?

No.i have google denied just about everything on my phone, and use here maps rather than Google. Just need to make sure hubitat has permissions, can run in the background and is not optimized. Even then you still will not be 100%. The last few days seemed like the geofence had been correct about 85-90% of the time.

My geofencing has refused to start working.
It was working on my phone (Samsung S8), a tablet (android lenovo), and another tablet (android lenovo no. 2).
Installed version was before 1.6.4 on all of them. It worked fine detecting presence and absence when I moved the gPS pin on the map.

I logged out of the app one at a time on each device.

I logged back in and selected the appropriate device that I was using.
A second device in my hub was created (duplicate device) for some reason, but I deleted the one that was not on the app's ID.
NOW I do NOT have a GPS circle anywhere in the world and it indicates that i am out of my geofence , The GPS pin has my location correctly, but NO circle whatever I do.

The debug log indicates lat/long 0.0 with a rad of 800 even though the log has my GPS location listed as the correct coordinates.
For some reason, the location is not being updated in the app, so it never sees my coordinates.

Yes, I have checked MANY times about the battery use, location permissions, and they are all enabled, but for some reason just logging out of the app corrupted something and it will not "restart", and I have "sent GPS event" many times, but didn't work.

Anyone have any ideas?
Where can I get the previous version?

Download the Hubitat app