Geofence Location Doesn't Match Hubitat Location

In my Hubitat settings, I have my location updated (, However, in the Hubitat app, the geofence location is located at 39.83333,-98.585522. How do I get the app to update to match the hub's location?

In the hub setup go to settings and then location and modes and you can set the hub location there.

It looks like you can do it in the app itself and it seems to work but then it resets itself back to where the hub says its at. I suppose you can try both if the app is reporting another spot. basically you press and hold on the hub icon and drag it where you want it at in the app. It will take a few tries to get it to move.

1 Like

You can tap and hold the pin on the app to move it to the correct location.


This did the trick. I thought I tried this before, but your post made me try again.

In case anyone else finds this issue, you can click the "locate" button while holding the pin and it will quickly move to your current location. That helped me a lot since I was over 800 miles away from my home.


This worked for me also. Setting it through the web interface doesn't work at all.

thanks had followed all other instructions and could not get it to update properly
thank you
have a great day

1 Like

That is the best way, I moved it from the US to Perú!