Generic ZigBee Lock - Issue after C8 migration


I have bought a C8 hub and migrated my C5 hub to it with all ZigBee and Z-Wave drivers.
Everything works fine except my Schlage ZigBee lock. It used to work perfectly fine with "Generic ZigBee Lock" driver in C5.

I tried to factory reset and join to solve, but it didn't solve the issue.
Most of the commands are ending with:
"[error] java.lang.IllegalArgumentException: Text must not be null or empty on line 643 (method parse)"

Only Lock/UnLock command works but it doesn't update any status of the lock and it always thinks the lock is locked.

Any solution would be appreciated.

@mike.maxwell should be able to ID what's causing the error.

1 Like

I think that your lock codes on the c5 were encrypted, and therefore can't be decrypted on the C8.
We will get this added to the migration instructions.
You should be able turn off the encryption option in preferences, then click configure.
This should read in the lock codes again.


Thanks, Mike.

Interestingly, I discovered that I do have encryption enabled on my Schlage Z-wave lock and it's having no problems after migrating (can control from HE)...Z-Wave and Zigbee locks must be using some different process, or ? @bcopeland ?

they use the same encryption/decryption methods provided by the hub

1 Like

Thanks for confirming...I guess I got lucky or something. Odd that having encryption on doesn't seem to have caused any issues on my Schlage.

Thank you for the answer! Yes the codes were encrypted in C5.

After disabling the encryption, I still get the same error. Do I need to delete the device and join it again as a new device?
I'm still using the same Device since I didn't want to sync it again in HomeAssistant, HomeKit, etc.
(But I'll do that if that's the solution)

Did you hit "Configure" after disabling encryption?

Yes, that’s how I got the error. GetCodes, Add, Delete, etc. also has the same error

1 Like

Can you post a screen shot of the device current states?, looking specifically for the value of lockCodes.

Yes, for now, I'll look at getting this handled more gracefully in the driver going forward.

1 Like

These are the variables.

Just wanted to update that completely removing the device and rejoin the lock fixed the issue.

Download the Hubitat app