GE Zwave Switch in strange state

I have a number of GE Zwave Plus switches installed - and I noticed today that one of them is not showing up in the list when I go to Settings - Zwave Details - but it does show up when I go to the list of devices. In addition - it does respond when I click on the on/off button from its Device Detail page. Not sure how to proceed with this one. Here is what the Device details screen shows in terms of info for this device:

  • deviceType: 18770
  • zwNodeInfo: D3 9C 00 04 10 01 25 27 73 70 86 72 77 68 23
  • deviceId: 12338
  • inClusters: 0x25,0x27,0x73,0x70,0x86,0x72,0x77
  • manufacturer: 99

The network id for this device is 06 and this device id is not shown on the Zwave details as I mentioned above. Also there are no "ghost" devices showing in that Zwave details list either.

Any thoughts on what the problem might be? I am running a C-7 hardware version of the Hub with firmware installed.

Could try to shutdown the hub and remove the power at the wall for about 30-45 seconds, and then power it back up.

1 Like

Along the same lines as @thebearmay suggested, whenever one my GE switches stops functioning pulling the airgap switch usually brings it back.

1 Like

Thanks for the suggestion - I tried that and so far no luck - the switch still does not show up in the Zwave radio device list. It does respond pretty quickly to clicking the on/off buttons from the main device list. One additional thing I have noticed is that the Current states lags a good bit before it updates to reflect the new switch state (off/on).

Thanks for the suggestion - one question on that - when you shutdown the hub like that - what happens to the Zwave mesh network - is there any effect - does it have to go through an internal resync to figure out the optimal routes - or is the mesh state unaffected by a reboot of the hub?

The routing seems to be continually churning on my C-7 ever since the 2.2.7 firmware series was first released. As long as it works, I just shrug my shoulders and don’t look at the routing.

This can be explained by the fact the switch doesn't appear to actually be Z-wave Plus . It is missing the '5E' command class in the inCluster section.

1 Like

Power down will clear the radio cached data, but by default the devices and hub should attempt to use the last known good route when everything powers back up. Thinking that clearing the radio may allow the hub to rebuild the zwave device table so that all devices are visible on the details page.

Thanks for the suggestion. I tried this out and unfortunately the hub never shows this switch in the Zwave device details screen. And while it does respond to commands - it does not respond to a second command close in time immediately - there will be a noticeable delay before it will respond. I am thinking at this point that I should probably delete this from the Device list and swap it out with a newer Zwave+ compatible switch. Thinking there might be something flaky going on at the hardware level in the switch itself - but not sure..

Somehow you must have a reverse-ghost node?

Maybe try (if you can) excluding it, and re-including it and see if that makes a difference.

The plus stuff just works a lot better than the old stuff does. On a switch that gets used a lot, I would definitely upgrade. On something that you rarely use, maybe keep the old switch.

There are a few 700 series Zwave on the market now, and probably worth getting one over an older 500 series. The new Zooz 700 switches for example are very affordable and feature-rich.

Yeah - it seems like it is a reverse ghost node. Since I just upgraded to the latest firmware level (2.28.136) I may try excluding it and re-including it to see if I can get it reset correctly. Otherwise I may just replace it as I have additional unused Zwave+ switches on hand.

1 Like