GE switch dropped off network?

So I had a weird and first encounter with a GE light switch that would not respond to commands. It worked properly this am at 04:00. After that the logs stopped. I had to wait until after work to trouble shoot. I could turn the light on/off locally, but it looked like it had been factory reset somehow. I typically turn the blue led on when switch is off, but there was no blue led when on or off. This is usually the state of a brand new installed switch. So, I checked the z-wave device table, and it showed no route to the hub. I tried a repair, and the hub could not find the switch in question. I ended up removing the device from z-wave, then deleting the device in the device list. After that I was able add a new z-wave device, fix my apps and automations. The only idea I can come up with is one of the kids or wife did a quick 3 up, 3 down which factory resets the switch.

Anyone experience anything like this with a GE switch? System has been rock solid for 1.5yrs.

1 Like

I've never experienced this over many years of using different GE models. Usually if their Z-Wave radio dies, they are dead for good. You might be right that someone may have accidentally reset it, or maybe you have a failing device.

They are known for the radio .frying easily especially during power fluctuations. In fact they extended the warranties for 5 yrs due to this. Contact jasco who.make the ge switches and they will send you a replacement.

Ive had at least 5 fail. When you say you were able to add a new device ?was it the same switch?. not clear. If so the ok.

1 Like

I've seen reports that one of things to try is cut the breaker to it (air gapping doesn't shut the radio down) and see if that fixes it

Known issue with GE. Off/on the breaker fixes it. Very annoying (and the reason I've ditched GE for Zooz).

Only on the older Z-Wave (non plus) switches.

I have had a houseful of Jasco switches for years and have never seen anything like this, Z-Wave or Z-Wave+.


Just to clear things up a bit. I rejoined the exact same GE switch to the network. Also, the GE switches I have are Z+. I forgot to mention I did a power cycle to the switch and nothing changed. Usually when a GE switch acts up I am unable to turn the light on/off at the switch. Power cycling has always fixed that issue. One other bit of weirdness: The "type" of device was listed as "generic scene switch" when I first went to the device details. I use the "GE switch" driver on all those switches. Not sure how/why this got changed. I did the latest updates just recently and possibly happened then?

I also noticed another node not connected to the network while trouble shooting the GE situation. It was a NEO cool plug I use for energy reporting on the dishwasher. I tried a z-wave repair and it still would not connect. So, I moved the plug closer to the hub and did a repair. Found it right away and worked great. I put the plug back to original location, did a z-wave repair and I found it without issue. It seems to be working/reporting this am just fine.

1 Like