GE Smart Switch 14291 - Says initializing but nothing more

So I just installed a GE Smart Switch 14291, which is in the list of supported devices, and after installing it, it works manually just fine, so I initially tried to discover it, but that didn't work, so I reset the switch to factory defaults, turned it on for pairing, turned on Z-wave exclusion, told the hub to try to find z-wave devices, and it finds the switch, and it gives me the following message:

Found Devices:

   Found Z-Wave Device with id 03


I let it sit for a very long time, and it never changes, so I then go to my devices to look for it, but it is not there, so I then tried repeating the process and again it finds it, says it is initializing the device, but never completes and add the device. I got the very most recent update, which is, got that update successfully installed, repeated the discovery process and I still am unable to get it to work. At this point I'm at a loss as to what is going on or how to troubleshoot this, as I'm a brand new user to the Hubitat system, so I just don't know if I'm the problem, or if the hardware is the problem, and how to know where to go next to get it working.

If anyone has any thoughts or suggestions, I would greatly appreciate it! :slight_smile: Thanks!

Just as a quick thought, is there some way that I might need to load a firmware update on to the GE switch by chance? The hub is as up to date as I can get it, so just wondering if maybe the problem is somehow with the switch and it maybe just needs updating or something?

And just one more strange tidbit to add. I reset the switch while in discovery mode, and the hub discovered a second instance of this device, which is not surprising to me, but what I did find surprising was that about 20 minutes later when I attempted to discover this device again, it immediately found both instances, on being id 03 and the other being id 00, so it seems rather odd to me that it would right away pick up two devices when there should just be one. Anyway, just something odd that seemed like it was worth adding to the information list in case it helps point out where the problem might lie.

In desperation, I moved the hub into the same room where I installed the switch at and now it is basically 10 feet away from the switch. I reset the switch, put the hub in exclusion mode and then told it to detect z-wave devices, then told the switch to pair, and I still get the same exact issue, where it says that it detects the switch and that it is initializing, but it never initializes, and consequently I cannot successfully add it to my list of devices to use. At this point I'm out of ideas so any thoughts anyone has would be much appreciated!

It sounds like you've tried quite a bit. When you say you put the hub in exclusion mode you do mean inclusion mode, correct? When you are searching for new devices it would be inclusion. When you are trying to remove/reset devices it would be exclusion. I have a feeling that's what you are saying though.

Do you happen to have a second z-wave controller you can use to exclude the switch? Sometimes when I can't join a device to HE I find that excluding it with my Ring hub does the trick. If you don't have another controller, please try this sequence (possibly one more time) just to make sure. If it doesn't work then you should try opening a ticket with support.

  • Power cycle the hub
  • Put the hub in exclusion mode
  • Within a few seconds of putting the hub in exclusion mode tap up on the switch, tap down on the switch, tap up on the switch and tap down on the switch about 1 second apart. (This should exclude it from HE if it's still in the database and it should tell the switch itself to leave all Z-Wave networks)
  • (If you have a second hub at this point you can exclude the switch again just to be sure it let go of its previous Z-Wave associations. Skip this step if you don't have another Z-Wave controller.)
  • From a different device and browser than you have been trying put the hub in inclusion mode for z-wave devices.
  • Within a few seconds of putting the hub in inclusion mode tap up on the switch, tap down on the switch, tap up on the switch and tap down on the switch about 1 second apart. This should put the switch in pairing mode (it only requires one tap but I found them to sometimes be lazy) and the Hubitat should see it.
  • Don't try to give it a label or configure it here. Just click save.

If it still doesn't get through inclusion there is an issue with the hub or the switch.


Ah, codahq you are a genius!!! :smile: I am brand new to all of this, so I don't think I correctly understood the inclusion and exclusion modes, and from all of the reading I had been doing, I thought I was supposed to be starting the exclusion for some reason and then the inclusion. Despite my ignorance, the hub was still detecting the switch, but it would never initialize. I think the key thing is that I didn't properly understand what the exclusion process did, so when following your steps, I realized that I had never actually tried to remove the switch from the hub as I didn't understand how to do that, and I'm thinking that when I was installing everything originally, the hub had a "corrupt" something stored for that device and it was interfering with other legitimate attempts to join the device, so this time when I put it in exclusion mode and did what you said, HE did say an unknown device was removed, and then when I did the pairing of it again when in inclusion mode, it found it and it initialized this time and worked!!!!!! :smiley:

I'm slowly figuring all of this out, so thank you for your well written explanation of the pairing and removal process, and this better understanding I feel is going to greatly help me with future devices and ease some of the frustration in the learning curve! LOL Very much appreciate your help and by carefully following your instructions I was able to solve the pairing problem I was having, so thank you once more! :slight_smile:


You can mark posts as solutions to questions. This can sometimes help others in the future with the same question.

For future reference, new devices typically do not need to be excluded first because they don't have any previous Z-Wave associations. It can't hurt though. If you are certain that the device is new and ready to pair you can just do the inclusion part.

1 Like

I would have marked the post with the steps as the solution but whatever. :+1:

Thanks for the tip about marking things with the solution, and I have done that as suggested and I thought of that earlier and tried to find a way to do that, but I guess I was not looking close enough, so thanks for pointing that out and I will try to remember to do that in the future as well. Thanks once again for your help and your information has greatly helped me out! :slight_smile:

1 Like