GE/Jasco switch updates physical state but won't respond to digital commands

I have a GE/Jasco Z-Wave Plus switch that I'm trying to move from my old C-4 hub to a new C-7 hub. I can't get it to exclude on the C-4 hub. It also doesn't respond to digital commands. HOWEVER...when I turn it on and off, it updates state on the C-4 hub it's definitely talking, but maybe not listening for commands? I also tried to do a generic exlude/reset using the new C-7 hub and it's not found there either.

Next step is to move the hub closer to see if it's a new range issue (it's been working fine for months), but figured I'd post here before moving hardware around to see if anyone has any ideas.

Turn it off at the breaker. Wait a minute and power it up again. Or use the air-gap switch to do the same.


Just tried that, no change. Guess I'll be moving the hub closer. Wondering if I have yet another dead switch....if so, this would be a different failure mode than the rest.

1 Like


Try this first. Shutdown the hub and remove power (from the outlet end and not the USB connector). Wait a minute, and power it back up again. The hub's z-wave radio can also enter a funky state and this would clear that.

I ended up moving the old hub and got it to exclude ok. Couldn't get it to include to the new hub...I think range is an issue. Tried adding a repeater too but no go. Will be replacing with either ZigBee or Lutron...trying to research which is less affected by the metal outdoor box the switch is located in.

I'm not sure what changed, the switch is for my pool light, which has been working fine for months. Only thing I did was set up the new C-7 hub next to the old C-4 hub, and now zwave on both seems weak. Could they be interfering with each other?

My zwave network is admittedly weak....most of my stuff is either ZigBee or Lutron at this point.

I would assume that they could interfere with each other since z-wave uses the same frequency on both.


i had these issues with a switch when i would experience power blips. a factory reset and re-pair of the switch would fix it until the next one. thankfully haven't had many power blips recently, but my next step is to replace the switch as i only have 1 out of many that do this

1 Like

I got all my zwave devices moved off the old C-4 hub and disabled it's zwave radio. Was able to get the switch to pair to the new hub after that. It's still slow to respond, and occasionally misses commands, so I think it's at the limit of the range, but I think having both networks up at the same time may have contributed a bit of interference. Nothing to back this up other and a mostly uneducated opinion though.

1 Like