Fully Kiosk: Dashboard not updating changes in status

I noticed this too. Just saw this post yesterday and trying it now.

Also shows green. Just had it happen again. Dashboard showed no switches on and had two that should have been showing. Tried to arm HSM and brings up keypad and once I enter, the display still shows as disarmed. Refreshed the dashboard and then shows the two lights on and now the correct armed HSM status.

Is this using FK?

One thing to try is to install google Chrome - it will update the webview stuff that FK uses.. I have not done this yet. At least that is my understanding from some of the XDA threads I was reading. When I run FK a message pops up saying the Webview is outdated.

My FireHD tablet has been running well - I just checked it after letting it sit all morning. I did what @Royski suggested with the FK's Other Settings and made sure the "Smart Suspend" option in the Amazon battery settings was turned off

Note: I have not yet removed the Amazon apps etc like I mentioned in an earlier post from THIS tablet.

1 Like

On Android 5.1, V 37 of web view is the latest I can get on one tablet (not a fire).
On that tablet I can no longer get to the Dashboard URL, although you can update manually here.

But not compatible with 5.1 :+1:

I have been using FK with Websockets for ages outside of the new dashboard and I can attest you that FK isn't killing websockets. Anyhow, I have FK running with the new 2.0 dashboards and I don't see any problems.
EDIT: I suspect it might be more an issue of the underlying OS/Webview that the tablet is running. You know, you can't expect IE6 to display the dashboard with all features correctly too. Even the rendering between different Webview versions is different. Had a problem that an older WebView version was not correctly resizing the dashboard either.

Yes,using fk

I would also add that maybe in FK under "Advanced Web Settings" set cache mode to "never use cache".

1 Like

I have a Huawei media pad 8" with fully kiosk dashboard 2.0 on 24/7 working fine here. Must be fire tablet settings.

Not just the fire tablets it seems. My new tablet did it last night.

Went to execute A switch, and the egg timer issue happened. I pressed the tile again, and the switch worked, but still just showed the timer. Almost like a refresh issue, I also have it happening on my iPhone X. But I think that’s just an issue with my phone. Although I think the others are just FK related issues.

I’ll be trying wallpanel later, see how I go with that.

This morning I tested the tablet with FK (I still have google apps installed, but FK is the "Fire" version). Clicking switches seemed to work okay but when I clicked on another DB on my laptop.. it took a couple of seconds to update and in one instance failed to change at all. Once I refreshed (by swiping right and going to the start url) things started working again. I should also mention I am using the universal launcher so I can include SONOS, When I go to the start url it puts me on the universal page and I click on the HE icon to get to the DB.

I have not yet noticed a slowdown thanks to the playstore.

Mine seems to be working ok again but based on my experience it will start to do it again. Every time I refresh the page it updates correctly. Need to figure it out for my wife and if we have someone watching the house /dog when we travel. I don’t want to have to give lessons on how to refresh the page if they come in and can not disarm the alarm because the page is not responsive.

In FK I just set a bunch of settings under "web autoreload". Will continue to monitor.

I think my next thing will be to have the lockscreen come on and make sure a refresh occurs when user gets back in.

Also just found this on XDA.. a way to change the default lockscreen wallpaper.

Note: I have NOT done this yet!!!! Being mostly ignorant of all things android dev am a little worried about "dm-verity" checks when mounting the system partition r/w.. maybe this is okay to do since my tablet is rooted.

The existing pics are okay but would like to replace maybe with family pics..


I posted the question on the Daydream/Wallpaper XDA thread will give everyone a heads up if I hear anything..

1 Like

This morning after leaving the tablet alone since yesterday everything is working and responsive. Click on laptop switch and a second later it shows up on the tablet. Click on the tablet switch and the same happens on the laptop. Will leave it be for now and check tomorrow. Trying to gauge any longer term issues - like with google play store. Right now tablet has been running constantly since Friday. No slowdowns noticed so far :crossed_fingers:.

Still considering lockscreen activation to prevent screen burn in.

I continue to have problems. Going to go through all settings again but think I have it set up as you do. Frustrating!

That sucks.. I've been trying to compile a list of things to do for these tablets..

  1. Enable dev options and set usb debugging on..
  2. Root tablet using XDA instructions.
  3. Disable/Hide unnecessary Apps.
  4. [Optional] Remove Ads/Special Offers lockscreen / change ls wallpapers
  5. [Optional] add Google play store.
  6. [Optional] install launcherhijack + alt launcher like Nova Launcher.
  7. Sideload FireHD version of FK from website.
  8. Tweak settings of FK - Priority (other settings)/Caching/Web AutoReload

Currently I am using the "universal launcher" feature of FK so I can also have my SONOS app available. I added the DB shortcut to the Universal Launcher and ran it from there. Not sure why that would make a difference though. I also have the dev option of keeping my screen active when power connected.

If I can think of anything else will mention it!

Here is a list of links for posterity and ease of future searching and frustration!!! :wink:

XDA Links to root HD8 2018

XDA Links to remove system apps (this is for older tablets but commands okay, use mtk-su and cut/paste commands into root shell)


XDA Links to remove Lockscreen Ads with Automate

XDA Links to change ls wallpapers (maybe use mtk-su instead of adbd) - WARNING NOT VERIFIED YET

Install Google Play Services

LauncherHijack - replace the amazon launcher with a different one

1 Like

Something interesting occurred today with the dashboard on my laptop. Had left it alone in a tab for a day or two. When I went to click on a switch, got the timer icon and the status of the switch did not update, I clicked a few others and got the same. When I reloaded all was well. I then checked my tablet which also had been sitting there and It WAS responsive.

I wonder if something is going on at the hub end..

*** UPDATE ***

On this thread @patrick said:

So maybe this is improved with the latest fw update. I have not installed this yet.

1 Like

Followed this thread and made all recommended changes, but my Samsung tablet running FK will randomly stop updating the dashboard. I notice that the green check mark in the upper right corner of the dashboard will ALWAYS stay green even when it isn't updating. I wonder what else I can try. On my iPhone under Safari everything seems to function correctly and I see the red exclamation mark even when it is out of date for just a moment, then it turns green again.