Fully Kiosk: Dashboard not updating changes in status

Pretty sure I enabled these yesterday after removing any apps I didnt need. The 7" was fine just now, which is great. Just in case, I also set to the 2.4 network instead of the 5 it was on.

New tablet working very well ATM.

1 Like

I use Fully Browser on my FireHDs, with launcherhijack set up fully as my launcher. to access other apps, i set up the "launchers" part of fully to include nova launcher. So far everything works great for the most part. I have found the tablet needs to be rebooted every now and then when becomes sluggish. unfortunately the fire tablets don't support the reboot command to be able to animate this with tasker..

Okay cool will add that - also found an XDA thread on that..

You can disable a bunch of Amazon apps:
https://docs.google.com/spreadsheets/d/1GLb_1xIWz1uGVEJEikwEaqRF0rhMVQI5vlMQcUm6m8U/htmlview

If you've rooted previously, run adb shell, go to /data/local/tmp, run "mtk-su -v" then copy paste the following commands in the terminal window

Here's my list (ymmv!!!) extracted from that one:

pm hide com.amazon.kcp.tutorial
pm hide com.amazon.kor.demo
pm hide com.android.deskclock
pm hide com.amazon.parentalcontrols
pm hide com.amazon.socialplatform
pm hide com.amazon.advertisingidsettings
pm hide com.amazon.calculator
pm hide com.amazon.client.metrics
pm hide com.android.music
pm hide com.amazon.dp.contacts
pm hide com.amazon.dp.fbcontacts
pm hide com.amazon.webview
pm hide com.amazon.client.metrics.api
pm hide com.amazon.pm
pm hide com.android.protips
pm hide com.amazon.webview.metrics.service
pm hide com.amazon.dp.logger
pm hide com.amazon.unifiedsharesinaweibo
pm hide com.amazon.kindle.personal_video
pm hide com.amazon.precog
pm hide com.amazon.weather
pm hide com.amazon.tahoe
pm hide com.amazon.mp3
pm hide com.amazon.photos.importer
pm hide com.kingsoft.office.amz

1 Like

If the websocket connection fails on local dashboards which is what gets the instant status, dashboard will fall back to background polling like in previous dashboards or cloud dashboards

The default polling is 2 seconds.

It also can take a bit for the logic to ultimately fail as the websocket tries to connect a couple times before failing.

I suspect FK is killing the websocket somehow.

Does the green check mark in the top right turn to red of the dashboard?

Always green here.

I noticed this too. Just saw this post yesterday and trying it now.

Also shows green. Just had it happen again. Dashboard showed no switches on and had two that should have been showing. Tried to arm HSM and brings up keypad and once I enter, the display still shows as disarmed. Refreshed the dashboard and then shows the two lights on and now the correct armed HSM status.

Is this using FK?

One thing to try is to install google Chrome - it will update the webview stuff that FK uses.. I have not done this yet. At least that is my understanding from some of the XDA threads I was reading. When I run FK a message pops up saying the Webview is outdated.

My FireHD tablet has been running well - I just checked it after letting it sit all morning. I did what @Royski suggested with the FK's Other Settings and made sure the "Smart Suspend" option in the Amazon battery settings was turned off

Note: I have not yet removed the Amazon apps etc like I mentioned in an earlier post from THIS tablet.

1 Like

On Android 5.1, V 37 of web view is the latest I can get on one tablet (not a fire).
On that tablet I can no longer get to the Dashboard URL, although you can update manually here.

But not compatible with 5.1 :+1:

I have been using FK with Websockets for ages outside of the new dashboard and I can attest you that FK isn't killing websockets. Anyhow, I have FK running with the new 2.0 dashboards and I don't see any problems.
EDIT: I suspect it might be more an issue of the underlying OS/Webview that the tablet is running. You know, you can't expect IE6 to display the dashboard with all features correctly too. Even the rendering between different Webview versions is different. Had a problem that an older WebView version was not correctly resizing the dashboard either.

Yes,using fk

I would also add that maybe in FK under "Advanced Web Settings" set cache mode to "never use cache".

1 Like

I have a Huawei media pad 8" with fully kiosk dashboard 2.0 on 24/7 working fine here. Must be fire tablet settings.

Not just the fire tablets it seems. My new tablet did it last night.

Went to execute A switch, and the egg timer issue happened. I pressed the tile again, and the switch worked, but still just showed the timer. Almost like a refresh issue, I also have it happening on my iPhone X. But I think that’s just an issue with my phone. Although I think the others are just FK related issues.

I’ll be trying wallpanel later, see how I go with that.

This morning I tested the tablet with FK (I still have google apps installed, but FK is the "Fire" version). Clicking switches seemed to work okay but when I clicked on another DB on my laptop.. it took a couple of seconds to update and in one instance failed to change at all. Once I refreshed (by swiping right and going to the start url) things started working again. I should also mention I am using the universal launcher so I can include SONOS, When I go to the start url it puts me on the universal page and I click on the HE icon to get to the DB.

I have not yet noticed a slowdown thanks to the playstore.

Mine seems to be working ok again but based on my experience it will start to do it again. Every time I refresh the page it updates correctly. Need to figure it out for my wife and if we have someone watching the house /dog when we travel. I don’t want to have to give lessons on how to refresh the page if they come in and can not disarm the alarm because the page is not responsive.

In FK I just set a bunch of settings under "web autoreload". Will continue to monitor.

I think my next thing will be to have the lockscreen come on and make sure a refresh occurs when user gets back in.

Also just found this on XDA.. a way to change the default lockscreen wallpaper.
https://forum.xda-developers.com/showpost.php?p=76071092&postcount=2

Note: I have NOT done this yet!!!! Being mostly ignorant of all things android dev am a little worried about "dm-verity" checks when mounting the system partition r/w.. maybe this is okay to do since my tablet is rooted.

The existing pics are okay but would like to replace maybe with family pics..

edit:

I posted the question on the Daydream/Wallpaper XDA thread will give everyone a heads up if I hear anything..

1 Like

This morning after leaving the tablet alone since yesterday everything is working and responsive. Click on laptop switch and a second later it shows up on the tablet. Click on the tablet switch and the same happens on the laptop. Will leave it be for now and check tomorrow. Trying to gauge any longer term issues - like with google play store. Right now tablet has been running constantly since Friday. No slowdowns noticed so far :crossed_fingers:.

Still considering lockscreen activation to prevent screen burn in.