Found a bug when creating complex rules


#1

I have been having this issue lately when trying to create complex rules. I get to the end of my rule and I have Ended the sub rule but then there isn't a selection to End the Rule. I usually have to Erase the Rule and start over and then sometimes it will be in the drop down list and sometimes it won't. I have done this rule twice now and it is still not showing so I can't complete the rule.

It did let me complete the rule actually this time but sometimes it won't.


#2

What is it that is "still not showing"?

When I create a rule like yours, the Done with Rule Definition button is visible throughout the whole thing. There are required inputs at certain points, in order to prevent the creation of a malformed rule.

Are you running into a required input or is the button not showing. Please explain...


#3

When I am creating a complex rule, I first select complex rule and then enter sub rule. when done with the first sub rule I select end sub rule. Then choose AND or OR and then select enter Sub rule. Then I choose the conditions and select end sub rule when done with that sub rule. Then there is a selection to End Complex Rule but it doesn't always show up. Sometimes all that shows is AND or OR and I can't finish the Complex Rule. And most times it won't allow me to finish the rule. I have to erase the rule and start again. Then I hope that when I get to the bottom of the complex rule it will have the option to select End Complex Rule and then I can finish the rule.


#4

I think you mean End Sub-Rule. Is that what is not showing up? There is no End Complex Rule.


#5

So here I have started to create a complex rule just to show you the problem. In the picture, I have the first sub rule done and I am doing the second sub rule. I am finished with it and I want to end the sub rule but I can't because it isn't in the drop down list to select. My only option is AND or OR but I don't want that. I want to finish the sub rule. At this point if I click on the Done with Rule Definition it will create the second picture, which isn't correct.


#6

Sorry bad example. I see that I didn't enter the second sub rule in the first picture. However, I have had this problem happen where I have entered the second or third sub rule but I can't end it.


#7

Need to see a failed example, since that one is not.


#8

I only tried once, but I was unable to duplicate.


#9

OK no problem. When I am doing another one and it happens I will post back here. Thanks! It doesn't always happen.


#10

What has pained me.. is that I forget that opening ( and I can't go back and insert/edit.


#11

Maybe that is what I am doing but I am sure that it isn't because I do it so carefully to make sure that I don't have to redo it when I get to the end.


#12

There's no really easy answer for this. "go back and insert/edit" is extremely tricky, as there is a not very simple state being maintained. The fact that rules can be nested to arbitrary depths makes this challenging. I'll take another look at it when Rule 3.0 dust settles. I suppose I could leave the option to turn on Complex Rule available while at the outermost level of nesting.


#13

Anything that improves on "Erase Rule" (the: start over entirely, this time do it right, button) would help. :smiley:


#14

You have to add another operator before you can enter another sub-rule. You can't have two subrules next to each other. You have to connect them with an OR or an AND. You can see from your screenshot that the AND or OR is what is required next. You can't pick a condition or sub-rule yet. If you pick AND then it will allow you to enter another sub-rule.Works perfectly for me.

Your screenshot cuts off the "Done with Rule" button. It's there. What browser are you using?


#15

Yeah see post 5. I already knew it was a bad example.


#16

So, I think one thing to do is to remove this "complex rule" thing completely. So that there is always an option of introducing a sub-rule. That both simplifies the UI and gets rid of the annoyance of having forgotten to choose that.


#17

Thinking aloud here... what about clicking "complex rule' and you are presented with an 'empty' set of parens.. all we would need to do then is pick the conditions and the inside relationship (AND OR)?

then for the outer AND OR, add another "complex rule" selection also.. which adds another empty set of parens.


#18

@csteele I like this idea!


#19

As long as you can click on something that let's you open another set of parentheses.
e.g.
((aaaa and bbbb)
OR
(cccc and dddd)
And
(eeee or ffff)
And
(gggg or hhhh))
And
Jjjjj.
I'm sure you get the idea.


#20

I like this idea. Just remove one layer and have everything available form the get-go. Removing one layer from the UI is a lot easier than re-designing it. :slight_smile: