Fix request for "Paused" rule status

I have a C-7 running

I'm using Rule Machine to pause and resume some Notifier apps. The trigger is a virtual button. The first action pauses the notifier rules. The second action resumes the same rules after a 5 minute delay.

After the rule runs, the notifier rules still appear as "paused". When I open each notifier app to manually resume them, the option presented in the top-right is "Pause" and not "Resume", as if to say the notifier app is currently active. When I close the app without making any changes and return to the main "App" screen, the paused status is cleared.

So, Rule machine is successfully resuming the rule, but the main App section still shows them as "Paused" in the list, making it hard to tell which apps are legitimately paused, and which aren't. I just wanted to request a fix for this to be considered in the next update.

The main Apps page does not automatically refresh itself, if I recall correctly. Have you tried simply refreshing the browser page after you push/hold the button?


I will second @ogiewon, a refresh is required to show both that the rule is paused and also that it was un-paused following this. (I just tested it to confirm).

1 Like

Thank you responding. I've tried refreshing the page. The only way I kind find to clear the "Paused" status is to open the app rule settings for each affected rule and close out again.

I am able to confirm this bug, and a fix will be in the next release.


Awesome, thanks a ton!