First time setup, can't pass step 5, LED is off

I am setting up a new C-7, I followed the instructions to plug in the ethernet cable and usb power cable, the c-7 led light up blue first and then solid green. So I went to getstarted hubitat com proceed to step 4, I clicked the find my hub button, and the hub was found. After I clicked the "My New Hub", I can never get pass the step 5, neither "update firmware now" nor "skip and continue" works. Currently, the led of my C-7 is off. What can I do to proceed here?


Support should be able to square you away.

1 Like

That is not good. Please be sure to create a case by following below link so we can furthe investigate:

The normal boot up cycle for the LED is Blue then Green. When you do a shutdown, it goes from Green to Red then Off.

Off means no power.. so maybe plug it back in as the first step? :smiley: :smiley:

I tried the unplug and replug the power cable, but the LED does not come back on anymore. But the ethernet cable connect to my switch is flashing, and my router is still able to assign an ip address to the C-7.

Do you mind sharing what switch make and model is the hub plugged into? Would you be able to use an alternative power supply on the hub?

I am using Unifi UDM Pro.
Tried with different adaptors and different cables, still no light. Now the device shows offline in the router. So it seems the power went on and off with the C-7.

1 Like

Thanks for the update. Please check your email.

Thank you.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.