Firmware upgrade from to on a C5: problems

I installed a new zigbee water valve from Sinopé and it worked so-so (because all the features were not recognized). So, I tried to upgrade the firmware of my C5.
Sadly, after that a lot (maybe not a lot but...) of rules were not working anymore.

My Caseta related rules are not working (motion => no light activation on various lights) and/or "advanced rules" like this one are working partially (no dim light while running, full light only) .

I also noticed that hubigraph is no more working as it should (I know that Hubigraph was discontinued due to some problems with the new firmwares) in my old firmware.

I didn't test my entire system, just noticed the obvious for me.

Your opinion on this: should I keep my old firmware as is on my C5 and install the sinope on a C7 I have (+ link between the C5 and the C7 like I do with other devices) or is better to reevaluate everything on my C5 (probably time consuming) to run the latest update ?

Thank you

Note: I reversed the firmware (to and all is working as expected, including Hubigraph

Updating the platform shouldn't have affected zigbee as no changes were made to the zigbee stuff. Shut down your hub and unplug for a half hour. This will throw your zigbee devices into panic mode. When your hub comes back up let things settle for 24 hours. That said you mention it only worked so so. They are a very reliable unit so for it to work so so indicates a weak mesh to me. You may want to try a mains based repeater closer to it.

Thank you for your reply.

In fact, so-so was not the best description. My zigbee is working fine since months/years. The so-so was related to the new Sinopé that was recognized as a zigbee device but not a valve, but...
Hold on, I'm maybe wrong, but at first I installed the sinopé and didn't find the valve in my old firmware (when you click on the dashboard icon, you have a "are you sure ?" message that works with the new firmware). That was the main reason of my firmware upgrade.

Since I restored the old firmware, I'm now able to set a valve as expected. Strange.
I remember why I decided to upgrade: the Sinopé battery level was not displayed on my old firmware. After the upgrade, all the information is there. After the downgrade, strangely, the info is still there (valve icon and battery state): any clue for this mystery ?

I'll follow your advice and install the latest firmware and let the zigbee mesh drop for a while and see what happen then.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.