Firmware Updater URL

Can someone tell me what the proper URL is supposed to look like on the driver page for the z-wave firmware updater custom driver? Thanks

What do you mean? Usually for z-wave you simply download the firmware, then through the updater send the file to the hub, then update the device. Or if you're talking about how to install it, simply go to the HE admin page, click apps, built in apps, then add Device Firmware Updater

1 Like

If you really want to use the driver, any HTTP or HTTPS URL that is a direct link to the firmware file, like one you'd download using a browser, should work. You can't, for example, use the address of a webpage that just contains a link to download a file (but copying the address of that link might work). A couple manufacturers with notable numbers of Hubitat support sometimes even provide these URLs directly (Inovelli and Zooz come to mind).

But if you're on a C-7 or later and haven't considered the built-in Device Firmware Updater app instead, I'd consider that first — it's a bit easier to use. All you have to do is download the firmware file (or otherwise obtain it) and then upload it to the hub using this app, then apply it to the device using the same — all without messing with a different driver or needing to get a URL directly or otherwise host the file somewhere. This more common scenario is what the reply above is assuming.

Need more info to provide the best assistance. What hub model do you have? What device are you trying to update (make/model)? What security level is that device paired with?

The app that @bertabcd1234 mentioned unfortunately has a bug and does not work for devices paired with S2 security.

Thanks, I have a C7 and I did not know about the built-in driver. I am trying it now with a zooz zen15 power switch. It appears to be working fine.

Thanks for the heads up on the S2. Fortunately I have not paired any of my devices using S2. I don't have any devices that would need it.

Thanks, I downloaded the built-in one as you and others suggested and I am using it now.

1 Like

May want to check this out then as well if you are not using it already: [DRIVER] Zooz Smart Plugs Advanced (ZEN04, ZEN05, ZEN14, ZEN15, ZEN20, ZEN25)

1 Like

Thanks, I will take a look.

@bertabcd1234 , @jtp10181 , @rlithgow1 Any of you guys know if .gbl files work with the updater? I read where only otz and hex files are used in HE. Is this true? Some of the firmware files from zooz are only in gbl format.

.gbl work fine with the built-in updater (still not on S2 devices though, unfortunately).

1 Like

Great! Thanks. No devices with S2 so should be good.

Yes, the built-in firmware updater has documented the file types that work: Device Firmware Updater | Hubitat Documentation

Or for the driver, you'll need to use the "binary" version (way down in that thread; the one in the original post will not work with these files).

Ok, great. Thanks for the info on the file types accepted. Not sure what you meant on this.

The driver would be the alternate approach you mentioned in your first post before settling on the app. The binary version would be the one from this post rather than the original: [RELEASE] Z-Wave Firmware Updater - #860 by bcopeland (probably not needed if you're sticking with the app, but for anyone else who see this and wonders... :slight_smile: )

1 Like

Okay, got it. Can a update be ruined if the device was turned on during the update? The other updates I did ran up to 100% in a consistent manner and worked (not turned on) but the zen04 I tried to update got turned on accidentally during the process. It was showing 8% then it would shoot up to 53% then back to 16% and back up to 56%. This doesn't act like the others.

What happens if you abort the process and restart it over?

Firmware won't be replaced until all checks and balances are done so if it's turned off in the middle of the update it should be fine

Oh good! I did turn it off as soon as I saw it had been turned on. Fingers crossed.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.