Firmware update for aeotec shutter

There is a update for the nano shutter, it looks like it might become a useful shutter device after all.


I have updated these (not a easy task unfortunately as it wipes the device) and once it's done I can confirm it is no longer a piece of junk. It now can be calibrated, works with the standard shade driver and let's you set the % to open to.

If your using the C4 stick like me to update my advice would be to delete it from hubitat (correctly) then re add it and update it which once done your then need to force remove it. Then add it again this is because Forse removing it when it's a "part of your mesh" seems to send everything Cady wompus. But Forse removing it when it's not in the rest of the devices tables doesn't.


Does anyone have and can share the firmware in hex or binary format so that I can use the built-in Z-Wave Firmware Updater tool in Hubitat? I tried to extract it myself (using bin2hex and other tools), and was able to get some files out. But whenever I try to update the firmware in the device, it always results in Device Firmware Updater: ERROR: Insufficient memory, so I probably got something wrong.

I'm looking to upgrade the Aeotec Nano Shutter (US version) from version 2.02... I tried several things and ready to give up on them. I have several of these devices, and some don't work unless the hub is right next to it, but stop working even if the hub is 10 feet away with direct line of sight, and also some other nano shutters right next to it (that do work) and should be able to mesh with it. I'm hopeful that a firmware update would fix them.

I think there is another post somewhere with the US version. I currently only have the EU one.

hmmm, no, unfortunately it's not (or at least I searched very thoroughly for months and couldn't find it, but maybe I missed it?). There are some US firmwares for the Range Extender and other Aeotec devices, but not for the Nano Shutter.
It's possible that someone extracted the firmware already, so I would really appreciate it if they can share it with me.
Thanks a lot in advance

I can extract it I just have to get to my PC and sort it all. in the meantime will look to see if there is a link.

1 Like

@juliandom try this

I have no way to tell if it will work, just let me know what the logs say.

If it doesn't work it will just fail to update and continue working and ill tweak the hex. If it does work and your going from <= 2 firmware to >=3 firmware it will disconnect the device from your network so you will need to then re-join it then delete the old dead node.

Thanks a lot for this. I'll let you know when it finishes. I was definitely doing something wrong, since my extracted hex was about 3KB.
I started the update 12 hours ago and it's going veeery slowly (it's at 60% now). Hopefully that's normal

1 Like

Thanks a lot, the update finished successfully after almost a whole day. And the good thing, is that the Z-Wave radio issue seems to be resolved!!
What was odd is that it recognized the device as "RGBgenie Micro Switch ZW-4004", but after changing the assigned driver, everything worked correctly.
Just a note for others having issues with this device, I'm using the Generic Z-Wave Shutter, which seems to work better than the Aeotec Nano Shutter driver.

Again, many thanks @BorrisTheCat ! I'll update my other devices now

That's not odd that was a bug reported age's ago but I thought @bcopeland fixed it with the updated finger prints?

Yeah there is some issues with this driver I think it's because it's bases on the old firmware.