Firmware 2.2.4 and Aeotec Door/Window Series 7 issues

Not yet :tired_face:

I’m doing it right now, will report back.

1 Like

I just did it also and the firmware went thru and updated. I also excluded and included and it seems to be working good with the S2 security. I did my on a C-7 Hub with the new built in app "Device Firmware Updater. This was my first update with the built in app and I like it better.

Yes! I did so using FW build 2.2.4.145. Using the C7's Native Firmware Updater app.

I’ve only tried 30-40 times in every possible combination of button presses, arm movements and tin foil placement. Even made the wife leave the house for an hour. Nada, zip, zero, no.

1 Like

Well, no luck using the binary firmware updater device driver, which was the process that was suggested by Chris of Aeotec (@ccheng). Here is the result of trying that on my C-7 running 2.2.4.148:

Error Logs

It may be that the Binary Firmware Updater driver by Bryan Copeland (@bcopeland) was specific to the C-5 and earlier Z-Wave radio and stack, or that something in 2.2.4.148 broke the driver updater on a C-7 running 2.2.4.148.

I had previously used the Firmware Updater driver months ago, on an earlier firmware version on my C-5, to update my Zooz ZEN16, which was part of an early production run whose firmware did not match the firmware version on the ZEN16’s underside, so I know that I can make the driver approach work on my C-5, but I have never used it on my C-5 running 2.2.4.148. I have used the Device Firmware Updater app on my C-7 running 2.2.4.145 to update my ZEN16 to its recent firmware update.

So, now, it seems I have a few choices:

(1) try my C-5 on 2.2.3.148 (the oldest firmware the Diagnostic Tool will allow me to restore) with the Firmware Updater driver;

(2) try my C-5 on 2.2.4.148, the version it is currently running, with the Firmware Updater Driver;

(3) try my C-7 on 2.2.4.148 using the Device Firmware Updater app.

I was unable to update the firmware on the Aeotec using the Device Firmware Updater app when I tried before, but, apparently I ran into two Firmware Updater App bugs:

(a) any update following an update for a now-removed device would fail. Because Zooz requires that the ZEN16 be removed, reset, and included following a firmware update, the Aeotec update failed. Workaround, until this is fixed, is to delete the Device Firmware Updater app and add it back.

(b) the “sleepy device” issue that Bryan has now explained.

I will try again.

Sigh.

TLDR - success! 3 Recessed Door Sensor 7 devices with updated firmware 1.05 that all work. Details below, perhaps this will help others.

After many unsuccessful attempts, and with the hints from Chris at Aeotec (@ccheng) and the “sleepy device” hints from Bryan Copeland (@bcopeland) and the clue I got from this post from @scottgu3 regarding a feature/bug with the Device Firmware Updater’s File Manager, I can now reliably and repeatably update an Aeotec Recessed Door Sensor 7 on my C-7 running 2.2.4.148. I have not done regression testing on my C-5 or C-7 using the Binary Firmware Updater driver using variations of this method, but this might point you in the right direction.

As some of you know from this thread, I’ve been around the block a few times with my Recessed Door Sensor 7 devices. Read that thread if you want the history and prior attempts at making them work (support certainly didn’t want to read that history).

I had one Recessed Door Sensor 7 that didn’t report a Serial Number, Firmware Revision, Hardware Version, or Protocol Version, and that lagged turning on the light by five or ten seconds first thing in the morning, and then lagged a few seconds after that during the day:

Bedroom Closet Sensor before

How it looks now

The firmware has been updated, everything is reporting correctly, and no lags. For the others, they now have updated firmware and work fine as well.

Here is how I got there on my C-7 with 2.2.4.148. Some of these steps may be unnecessary red herrings, but this is a process that worked for me.

The Device Firmware Updater is great, but has a few rough edges, as can be seen from my earlier post upthread. So, I deleted the Device Firmware Updater and added it back, then cleanly shut down my C-7 to red light, pulled the plug, and rebooted. This was to put the Z-Wave Radio in a known good state after all of the Firmware Updater errors.

I then excluded the Recessed Door Sensor 7 (after substituting a virtual device so automations didn’t break, a trick I learned from Ashok Aiyar (@aaiyar)), reset the RDS7 to factory defaults so that I was working from a known state, then re-included it, choosing the Aeotec Door/Window Sensor 7 Series driver. As Bryan Copeland (@bcopeland) instructed, I disabled that device (faint X in upper right corner of devices page, then X in first column for that device).

Because of the errors I was getting with Device Firmware Updater app, I decided to delete all firmware files in the Device Firmware Updater’s File Manager except the file for the RDS7. This is tricky because the DFU’s File Manager has (previously unknown to me) inaccessible options off the right of the screen (at least on my 512 GB iPad Pro 10.5 inch using Safari on iPadOS 14.2). After seeing this post from @scottgu3 regarding the DFU’s File Manager interface, I moved to my iMac, which has a wider screen than my iPad (even in landscape mode), and saw previously-hidden trash can icons at the right of the screen, allowing me to delete previously updated firmware files, and also showing a previously-hidden confirmation answer to the “are you sure” question when deleting.

I moved the RDS7 near the Hubitat hub (8 inches away).

Then, using the trick from Chris at Aeotec (@ccheng) and suggestion from Bryan Copeland (@bcopeland), I depressed the wake up button on the RDS7 using a paper clip until the light turned red, then immediately released the button, noting that the light stayed on, indicating that the RDS7 was awake.

I then proceeded through the Device Firmware Updater’s procedure to Update Z-Wave Firmware, making appropriate choices of device and firmware file. The RDS7’s LED stayed on solid for the 5 or 10 minutes it took for the file to be uploaded to the RDS7, then DFU indicated it had sent the last packet, etc., so I waited awhile and then hit done back to apps. The RDS7 LED stayed on, and the only way I could get it to go out and make the device responsive was to remove and replace the battery.

Re-enabled the device, re-installed the RDS7, and everything worked, snappy response, new firmware version (1.05) indicated in the driver.

I have no reason to believe that a similar procedure wouldn’t work with the Binary Firmware Updater procedure outlined by Chris at Aeotec (@ccheng).

Hope this helps the next person, and thanks to Bryan Copeland for writing the Device Firmware Updater, finding the Aeotec firmware bug, and pushing to get the bug fixed.

4 Likes

Mike, while my posts had nothing to do with the S2 pairing firmware bug (because my Recessed Door Sensor 7 devices were always paired without any security), as you would have seen if you had read my posts, the solution to my issues was to exclude, factory reset, then re-include the Recessed Door Sensor 7 devices as a part of doing the Aeotec firmware update to 1.05.

Details upthread here.

Apparently this is why Bryan Copeland wasn’t able to replicate my issues using the current built-in driver. It may have been some vestige of the fact that my Recessed Door Sensor 7 devices were migrated from the prior built-in driver (“Aeotec Recessed Door Sensor 7”) on my now-idle C-5.

Perhaps this will help someone else having difficulty with their Recessed Door Sensor 7 devices.

Peace.

It’s now safe for her to come back.

2 Likes

:rofl: :rofl:

1 Like

Great stuff! I'm glad you tried the Mac, now I dont have to boot up my PC just to answer that question! :wink:

Awesome effort, glad you got it sorted out!

S

2 Likes

Thanks, Scott. I wouldn’t have had a clue how to get the DFU to work if I hadn’t seen your post about the interface. I thought perhaps it was a browser issue, when it was really a screen width interface design issue.

No one shall be permitted entrance through the door till the sensor works. Just as manual light switches are just something used to plug a hole in the wall. Y’all should know that’s the rules.

1 Like

Does anyone know how long to hold down the button to disable sleepy mode? Apparently, on the newest versions, they decided to do away with the LED so every time I've tried I have inadvertantly caused a factory reset.

Currently on 1.04 and they don't work at all after being paired.

Thanks

As far as I know, there is no way to disable sleepy mode on the DWS 7, but there is a way to wake it up when it is asleep, as for firmware update.

To wake up (as for firmware update), open cover, just tap the tamper switch. That’s how I did it on mine.

Once awake, it will stay awake until cover replaced. See top of page 9 in manual.

Here is the manual:

You can use Mike Maxwell’s to set the LED parameter as desired. See page 10 of manual. Worked for me.

Latest firmware I can find at Aeotec for DWS7 (non-pro) is 1.01, which I have.

Edit: I just re-read your post. Are you talking about DWS7 (the subject of this thread), or the Recessed Door Sensor 7 (whose firmware is at 1.05)? If you are talking about RDS7, see my post upthread:

It’s about 2 seconds on the RDS7.

Sure you don’t have ghost nodes from all the resets/pairings?

No :ghost: s over here.

I found a pdf online that says 6 seconds and that worked for me.

1.05 works fine. 1.04 doesn't work at all.

For anyone reading this, for me it was necessary to use the firmware update app as the driver version wouldn't work. They had to be paired without security. Once in sleep mode, holding the button down six seconds, I had ten seconds to start to process otherwise it would go back to sleep mode. Once the firmware was uploaded I waited a couple minutes and did a battery pull. Removed the device and re added with S2. The new firmware version didn't show until I re added.

1 Like

Mathew, struggling here too. How exactly do you disable the device?

Never mind. Man this is too tricky! Seems to be loading now. Thanks!

2 Likes

Just curious if everyone that has done the update has their reassessed contact sensor working with S2 security. I have tried one so far and it worked for a few minutes and then stopped. Now it only shows open/closed if I press the button first. Then it stops responding after about 10 seconds.

@matthewschultz92 and @leeonestop were the ones who reported the S2 problems to @bcopeland, who escalated the issue with Aeotec, and got firmware 1.05 released for the RDS7 with the S2 fix. I gave up when I finally got my 3 (now 4) Aeotec RDS7 devices working with no security.

Perhaps one of them is having success.

Download the Hubitat app