Firewall Settings (Hubitat to HOOBS / Homekit)

I almost got there, I thought I had a bug in the hub but I think it has to be the internet settings. I have the Eero pro I phoned there technical support and they recommended to forward a port, this only works for a short time for some reason. At the moment Hubitat will Register when a switch has been toggled manually and will turn the lights on and off through the app. The trouble is I need to forward port 8000 From Hubitat just for Hoobs to listen to Hubitat but Hubitat still its listening to HOOBS. So confused to be true I have the HomeKit page open and the HOOBS page open and the Hubitat page open and they don't communicate. Even tho Hubitat will Register when a switch has been manually pushed it won't send the info over but the buttons can be digitaly pushed in HomeKit

If they are all on the same LAN you do not need to port forward. I would not be forwarding any ports exposing your hub or hoobs interface, you might expose it to the outside world on accident.

Now if the device that hoobs is installed on has a native firewall, you might need to allow the ports through that firewall (not the same as port forwarding).

I had homebridge working on a windows machine previously, and just moved it to linux VM, I do not think I had to manually open any ports on either setup. I just followed the directions and it worked.

Are you using the Homebridge integration by totones7?

Everything is on pi, I had just put tailiscale on the pi running HOOBS to see if that would help

Everything is on the same Lan too, this has been bugging me for months., it worked for 3 days last week lol

I have Homebridge on a Pi (using the Homebridge image) and an Amplifi HDs in mesh mode. Have had no need to forward any port - it just worked.

On a different note - I had tried HOOBS before I went to Homebridge (about 2 years ago?) - gave up on HOOBS because it kept crashing my ISP provided modem. No one (either ISP or the HOOBS folks) could figure out why. Never had a problem since I switched to Homebridge :man_shrugging:t4:

yes its the totones7 plugin I couldn't work out how to do the makerapi one without freezing everything lol

How are you running Hoobs, did you start with the hoobs image for the Pi? Or are you running it in a docker or container of some sort?

Also, for the homebridge/hooobs hubitat plugin, did you use the generated config from the app in hubitat?

The totones7 hubitat app is so amazing when I moved my homebridge to another machine I just backed it up, shut down, restored on the new machine and it poof it took over I didnt have to change a single thing.

Funny, I have been using homebridge for a while and decided I want to try hoobs, I have it installed but have not migrated to it yet. Seems like it might be a slightly nicer interface and overall setup and I just want to check it out.

1 Like

I had a go with homebridge, I liked it to be true the dashboard is a bit better laid out too. Everyone says HOOBS is for noobs so I went back there but I can't see any difference in the easiness of the different systems to be true

I have HOOBS on my argon m.2 for some reason the image wouldn't work on my ssd so I manually installed it with ssh. I do love the way the app you mention our set up it seems straightforward but I can't work it out it seems lol

Oh - I use the MakerAPI one. I do have tonesto7's app also installed but only use it as a "test" instance (only a couple of devices shared and to a separate Homebridge instance on a Mac). Again - no port forwarding required.

1/02/2022, 21:49:00hubitattonesto7bridge stopping
11/02/2022, 21:49:05Hubitat Tonesto7 Bridge starting
11/02/2022, 21:49:08Hubitat Tonesto7 BridgeLoaded plugin 'homebridge-hubitat-tonesto7'
11/02/2022, 21:49:08Hubitat Tonesto7 BridgeLoading 1 platforms...
11/02/2022, 21:49:09Hubitat Tonesto7 BridgeHubitatBridge Version: 2.7
11/02/2022, 21:49:09Hubitat Tonesto7 BridgeHubitatPlugin Version: 2.5.14
11/02/2022, 21:49:09Hubitat Tonesto7 BridgeHubitatChecking Package Version for Updates...
11/02/2022, 21:49:09Hubitat Tonesto7 BridgeHubitatAdaptive Lighting Supported... Assigning Adaptive Lighting Controller to [Central front porch light]!!!
11/02/2022, 21:49:09Hubitat Tonesto7 BridgeHubitatAdaptive Lighting Supported... Assigning Adaptive Lighting Controller to [left porch light]!!!
11/02/2022, 21:49:09Hubitat Tonesto7 BridgeHubitatAdaptive Lighting Supported... Assigning Adaptive Lighting Controller to [right porch light ]!!!
11/02/2022, 21:49:09Hubitat Tonesto7 BridgeHubitatFetching Hubitat-v2 Devices. NOTICE: This may take a moment if you have a large number of devices being loaded!
11/02/2022, 21:49:09Hubitat Tonesto7 BridgeHubitatRefreshing All Device Data | Source: (First Launch)
11/02/2022, 21:49:09Hubitat Tonesto7 BridgeBridge is running on port 51856.
11/02/2022, 21:49:10Hubitat Tonesto7 BridgeHubitatINFO: Your plugin version is up-to-date
11/02/2022, 21:49:10Hubitat Tonesto7 BridgeHubitatSending Plugin Status to Hubitat | UpdateAvailable: false | newVersion: 2.5.14
11/02/2022, 21:49:19Hubitat Tonesto7 BridgeHubitatERRORgetDevices Connection failure | Message: timeout of 10000ms exceeded
11/02/2022, 21:49:19Hubitat Tonesto7 BridgeHubitatTotal Initialization Time: (10 seconds)
11/02/2022, 21:49:19Hubitat Tonesto7 BridgeHubitatUnknown Capabilities: ["Notification"]
11/02/2022, 21:49:19Hubitat Tonesto7 BridgeHubitatHubitat DeviceCache Size: (15)
11/02/2022, 21:49:19Hubitat Tonesto7 BridgeHubitatWebServer Initiated...
11/02/2022, 21:49:19Hubitat Tonesto7 BridgeHubitatSending StartDirect Request to Hubitat | UsingCloud: (true)
11/02/2022, 21:49:19Hubitat Tonesto7 BridgeHubitatDirect Connect Active | Listening at
11/02/2022, 21:49:20Hubitat Tonesto7 BridgeHubitatERRORsendUpdateStatus Connection failure | Message: timeout of 10000ms exceeded
11/02/2022, 21:49:29Hubitat Tonesto7 BridgeHubitatERRORsendStartDirect Connection failure | Message: timeout of 10000ms exceeded

why do you think mine required it just to be able to see the app know when the switch has been pushed manually and only for a short time. I have removed all port forwards now. I will try adding a firewall to port 8000 for both Hubitat and HOOBS again, I have done it before and again I think it worked for a short while. It would be nice if it was more stable or if I knew if I was just getting closer

Any particular reason you have the "Direct Connect" configured? In my test instance of Homebridge, I have it blank. If you populated it for a reason, is it the correct IP address for the hub?

yes this is my direct ip and I populated this, I don't think I have ever had it working locally when it has worked it was with the cloud. I have reset this hub and used a previously saved static IP address. is it possible that the IP address is invalid?

I just blanked out the direct ip bit

just reloaded and there's no red writing just going to check a Switch

If you log into your Hubitat hub, select "Settings" from the menu bar on the left and then "Hub Details", it will show you the IP address of your hub

omg that was it thank you so so much :blush:

1 Like