Fibaro RGBW Controller 2

So tomorrow I am going to be contacting support, but thought I might reach out here to see if someone might have an idea.

I have a new Fibaro Controller 2 device and it won't be found on the z-wave network. I have followed the auto-discovery (start discovery plug it in) and the manual discover (start discovery and push the button 3 times). Neither works. It also does not appear that the button works. Pushing it one time does not turn the lights off. It is on so 2 times is moot.

Any ideas?

Don't sound good and I doubt HE support can help with a dead device. Was it working before? If so have you tried following the instructions to do a factory reset on it? It may just not be excluded from the old controller. Also what firmware is it on?

It is brand new out of the box. Not sure of firmware. I am reaching out to Fibaro support today. I was just wondering if I was being stupid and missed a step that someone here could point me in the right direction.

I contacted Fibaro support and the controller 2 I received was faulty. I should have another one in a day or so thanks to Amazon return policy.

1 Like

is rgbw 2 from fibaro is working fine with hubitat?

quite literally just moving it to my C-7. It worked fine on my C4 i have also updated the firmware on it to the below so hopefully that doesn't cause any issues!

No there seems to be some issues with it on the C-7 :pensive: Sorry @mike.maxwell looks like another one that the C-7 is causing issues with.

Any details?

was just doing some :smiley:

@mike.maxwell. The main issue seems to be with the switch state AND OR using the white child channel. I have to hit refresh to get it to update no matter what. When the white child is used the current states never get updated.


as above my firmware is 27.27! I would assume that is going to make a difference as i updated mine with their hub.

some errors if useful.

and example of the states not changing even with refresh. no colour mode

no christmas lights this year. Does anyone have a working driver?

I'm using Fibaro RGBW 2 Controller with Zooz RGBW Dimmer driver and it is working fine

great will try that now!

no same problem the current states never appear

in my case it shows correct status... firmware 5.0

My firmware is like 27._ something I think

Fibaro RGBW Controller 2 is only with 5.X firmware


I joined it to their hub and upgraded it from 25. to 27

so you don't have RGBW Controller 2 but 1

It was definitely a controller 2 when I brought it

Edit: actually one of mine is the controller 1 and the others are 2. I brought them as 2 but that explains why one has always been odd.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.