Fibaro RGBW 441 problems with LED strip lights

I am just getting my HE set up, it's actually an older device that I've had for a little while, a C-5. I'm trying to use an older Fibaro RGBW 441 controller with a RGBW LED strip light.

I am powering this with a 25W 12V DC LED dimming driver - KVP-12025-TDL.

I was able to successfully identify and include the Fibaro as a Z-wave device. I created a dashboard and added a Color Bulb. I can get it to turn on and off in colors, but the colors aren't correct.

When I go to the device itself in Hubitat, I can get the device to turn On and Off when selecting those options, as well as enable effects, ie 5 Police. I can also turn on the Warm White Level, but this doesn't seem to be effected by On or Off - those only control the colors.

Furthermore, the colors are wrong. When I set Red to 100, the lights are green. When I set Red to 0 and Green to 100, the lights are blue. When I set Green to 0 and Blue to 100, the lights are red. WTF? I assume something is wrong with the driver, or the fact that I am using an older Fibaro RGBW (first generation). I've double checked that the wires are all connected correctly.

I will try switching the wires around to see if I can control it as desired from Hubitat, but I shouldn't have to "fool" it by connecting the wires to the wrong terminals.

So when I connect the red lead from the Fibaro to the blue terminal on the LED strip, the green lead to the red terminal, and the blue lead to the green terminal, it seems that I can control the colors from the Dashboard or Device settings 'correctly'.

I suppose this is a work-around, but it would be nice if the driver (I'm assuming) would work correctly with the controller and the wires connected appropriately as they're labeled.

The next problem I am having is being able to control both the colored LEDs (check) and the warm white LEDs (no-check).

When I go to the Device, I can manually set the Warm White Level, but I cannot figure out how to set up the Fibaro from the Dashboard to let me control this. Appreciate any help.

The built in driver is for the "newer version" so im guessing that the older 441 connections were different. Its less likely they will create a driver for the older version and if this works its a good work around.

the driver has the option to create a child dimmer device.

this will create a seperate device for the white channel and then you can do what you wish with it.


Thanks! That explains why there was a 'new' device listed below Fibaro RGBW Controller called Firbaro Dimmer.

Just created a new app to turn the warm white light on and off at specific times. Seems to work so far.

1 Like

This was exactly what I needed. Thanks, Fibaro RGBW works exactly as I want now,

1 Like