Fibaro FGS213 Single Switch 2

Hi all
I have just included a new FGS213 Single Switch into the network.
HE detected and has set it up as a stock Fibaro Switch device.

The On/Off are working but the state isnt reporting.
Checking the logs shows this -

I then tried the stock Generic zwave switch but nothing worked.
Screenshot 2020-06-28 at 15.34.05
Any suggestions?

I use these drivers

Yes so do I especially for power monitoring on the FGS223 :wink:
I tried his FGS213 driver and nothing happened even after save preferences

Did you also click on configure?

I will check and report back thanks @djashones

Hi again
So the Configure has been selected and the state is image
However the On & Off do nothing to the state of the switch!!!!

Does it use child devices like the double switch?

No its a single switch so doesnt need Children
@ericm, do you have any suggestions please?

Well, I'll report back in a few days. I some brought some :smiling_imp:

Okies
I have re-read the Fibaro instructions, refitted the Fibaro module and refreshed/re-configured the switch and it works.
What has changed, well I rewired the live feed to 1 of the L on the module and then wired the other L to the Power on existing switch.
Before I was wiring live to the module and the switch seperately...

1 Like

Hi all

Recently I have noticed these debug messages from @erocm123 or is it @eric17 's Fibaro FGS213 Single Switch 2 device driver

Any suggestions?

Wrong eric?

Just got around to installing mine and they work fine and as expected.
hub: C-5, FW: 2.2.4.148

Yes they work fine but was interested in this debug message to understand what was causing and what it meant. Through platform updates things do evolve in the zwave stack

Something to do with the energy meter. I'm using the latest driver, last updated 17th June 2020. Apart from this I don't have a Scooby

I dont know the exact version as I just link to the driver here https://raw.githubusercontent.com/erocm123/Hubitat/master/Drivers/fibaro-single-switch-2-fgs-213.src/fibaro-single-switch-2-fgs-213.groovy

I don't know. I might face the same as you, once my lights are on long enough to start reporting kwh

I will check my energy reports

1 Like

Firstly I have C5 running 2.2.4.148

I have updated the FGS213, FGS223 Switch 2 handlers and Metered Child from his github repository.
I am still getting debug message on the 213 Single Switches such as -

And now the 223 Double switch Children are responding but the dashboards update slowly and the Parent Device is complaining -

I wander if this is to do with zwave stack?
Any ideas

I don't have a clue. Just updated my double switch drivers and mine seem fine. I use homekit as my dashboard and response as expected.

Download the Hubitat app