Fibaro dimmer 2 state not refreshing

Hi All,

New convert from smartthings and i've finally moved all but one of my devices over to HE. However i'm having an issue with my fibaro dimmer 2.

If i turn it on via the wall toggle switch, the lights turn on, but it doesn't seem to ever update the dashboard or the device page to state that it's on (it does update if i click refresh on the device page).

This is causing me an issue as it's my bathroom lights and i want it to trigger a fibaro double switch to turn on my bathroom fan. The annoying thing is it worked with smartthings (all be it with a 10 odd second delay).

Could someone please point me in the right direction to try and resolve this.



Have you tried the stock HE 'Fibaro Dimmer'?

I'm using it and it is working OK.

Sorry, yes i am using the stock driver i don't have another driver for the dimmer installed either.

If i use the dashboard to turn it on, it updates straight away, just not when using the toggle switch on the wall.

have i naffed up the pairing? I did take it out of the loft and bring it into the same room as the hub when i moved it accross. Or can i use a motion sensor to force a refresh of the dimmer?

Hmm. I've not looked at mine.
Will go try now.

EDIT: Just tried mine that is installed in the bathroom. It came on with motion and the dashboard updated. I have a pull switch which when pulled to turn light on and off, the dashboard responded correctly so it looks like mine is working OK.
Mine is also set as a toggle switch.
Not sure what to suggest.

Thanks for your help and for checking, i tried setting the motion sensor to trigger a refresh of the dimmer, but it's not in the list for it.

Gonna try a custom driver next and see if that helps. If not guess i'll go drag it out again and re-pair it with the hub tomorrow.

I've had this on the hub for some time and I'm fairly sure I had it using a custom driver before the 'In House' one was available.
Trouble is I have 3 and I'm not sure which one I used. I can PM all 3 to you if you want and give them a try. I would try on mine but I'm loathed to do it in case things screw up.
Want me to send them?

EDIT: Or try this one here?

Cheers for that, i'm going to try the erocm one, as i use his one for the double switch.

I'll have to wait till tomorrow now as the kids are in bed.



Managed to sort it, by switching to secure inclusion, didn't realise it was only locks etc by default.

That's interesting and this has jogged my solitary brain cell.
I believe all zwave devices used to join using secure inclusion but then HE changed things so that only locks did. They then encouraged people to change to insecure joining apart from locks which I did.
As long as you have it working is all that matters.

Yep as usual the problem was in front of the screen. lol

Now all i need to do is move my ST presence sensors over and then see if there's a way to connect my hive heating to hubitat and i'll be able to turn the ST hub off.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.