Fibaro Dimmer 2 FGD212 Pairing Issues Solved


I am in the process of migrating from Vera Plus to Hubitat C8 (“HEC8”) and was having a load of issues trying to include the Fibaro Dimmer 2 FGD212.

I managed to exclude the devices OK, but could not include them on the HEC8. I had tried resets, excluding, including and could not fathom out what was wrong.

The process below worked for me in the end on 4 devices :

  1. Exclude from old hub
  2. Press and hold button B until the Yellow light appears then release and press B again - this resets the device (yellow is after Purple).
  3. let the device do its own calibration
  4. press and hold button B until the red light shows then release and press B again to start a calibration sequence.
  5. Once you see the Green LED this shows that the device is calibrated
  6. I then waited a few seconds to let the device ‘settle’
  7. Start Inclusion on HEC8
  8. Press button B 3 times quickly

Good luck.


Now the only issue you may have later down the road is that those Fibaro Dimmer 2 modules do not support S2. Because of that it's very likely they will have included with S0 security which is very bad. Apparently S0 is very chatty and will slow down your network. I'd strongly recommend getting hold of a USB Z Wave stick and the SiLabs Simplicity Suite software (and load Z Wave Controller module). That will enable you to to include them with security set to 'none'

Unfortunately once they're included you can't change the security - you have to start again - excluding and then including the device without security. With a C7 or C8 that is only possible using the aforementioned method. It's nothing to do with Hubitat, it's down to how the SiLabs SDK works on the 700 and 800 series chips (enforcing inclusion with S0 where S2 is not available). I have about 16 of the Dimmer 2's and had issues early on.

Hi john,

Thanks for the insight.
I checked the device settings and see the following:

All 4 have the same S2:128 and zwaveSecurePairingComplete: true

Does this mean it has configured with S2?


1 Like

The best place to check is in your Z Wave details page in settings. There’s a column there for security. Ideally you would pair everything except for locks and garage doors etc with no security. I’m fairly sure it’ll show as S0 when you check.

Thanks for the advice. Unfortunately you were correct. They are all S0 :frowning:

I’ll take a look at your previous advice and look to fix it.

Thanks again.

Edit: just ordered an Aeotec Z-Stick 7 | Z-Wave Plus V2 | ZWA010 | 700 series

1 Like