Fade issue from 702 vs 703-704 [Edited issue description]

Previously I was able to set a fade time and my light would ramp to a set level from OFF. It was possible to do this from the light’s device details page or from RM. Now I’m unable to get the lights to do this. In the device detail page, [Edit] I can go from OFF to 70% with a 30 Fade time, and it works one time. I can also go from 70% to 1% with a 30 fade time and it works, and then I can go from 1% to 70% and seems work consistently, but if I go from OFF to 70% with a 30 Fade a second time, it jumps instead of slowly fading. Seems I can only make it fade one time. This was not the previous behavior prior to the 703 and subsequent 704 updates. Again, this odd behavior continues, even though I have reverted to 702 firmware and restored a 702 database.

I reverted to 702 and restored my 702 database (just to be sure) and it still behaves the same way. Were there some changes that might be affecting the core functionality that can not be reverted, even with a firmware downgrade?

Was there a change to the ZigBee White Color Temperature Bulb driver that would now affect any firmware? Do I need to try removing and re-pairing the bulbs and if so, should I try it first under 702 where I am right now for testing, or should I update to 704 again and then try re-pairing the bulbs?

One of my favorite Hubitat features was fade from off & fade to off, so I hope i can get it back.

We haven’t touched the Zigbee White Color Temperature Bulb driver during this period. There have been no changes in the platform that would affect this. All I can think is this has something to do with the device itself. The exact same commands are being passed now as were passed before.

Ok. Thanks for confirming. I’ll do some more tests tonight to try and figure out why they’re behaving so differently now.

After more testing I found that I could not duplicate the previous behavior, where I could turn off a set of lights using the ZigBee White Color Temperature Bulb driver and yet using a rule, they would fade from OFF to 70% each time. As @bravenel suggested, it is likely the bulbs. These bulbs I’m testing with are the Sengled Element Plus, and they are unique in their ability and it seems, their behavior.

What I did find was that if I turn off these bulbs with a rule that fades to 1%, followed by a command for OFF 3 seconds later, I am able to consistently go from OFF to 70% with a 30 fade every time. It is only if I simply switch OFF the bulbs from either the devices details page, from Alexa or via a rule, that they will not fade from OFF, but instead will jump abruptly to 70%.

This has me wondering about a possible future addition to, perhaps all the bulb drivers, where it might be possible to save a preference that specifies the defualt brightness level and fade time within the driver, thus allowing lights that do not have a built-in fade to mimic one that does. A similarity to this would be Insteon’s capability to specify default brightness (On Level) and Fade time (Ramp Rate) per device, yet Scenes are still able to override these default values.

I have rules that perform the requried actions for Fade 25 to 1%, dim level, then OFF 3 seconds later, as well as Fade 30 to 70% dim level. As long as I use the Fade to 1% then OFF rule, my Fade 30 to 70% dim level rule will work, so I’m using these with a Pico, but found it is impossible to use separate ON and OFF rules with Alexa and get consistent results. I ended up trying to create complex sets of routines that would cover every possible phrasing for turn off the Dining Room, but the end results were so inconsistent, I abandoned the idea, because it often results in a positive response from Alexa, but no action. Simply asking it to turn on the bulbs named “Dining Room” works every time, but the effect is my lights won’t fade because the bulbs themselves don’t have that feature.

This is most certainly a wish list item, and to be honest I’d much rather have Hue Bridge integration before any feature like this sees the light (pun intended :wink:). But it definitely would be unique feature that would further add to the experience of using devices powered by Hubitat.