Extra Functions on HomeSeer WD-200?

I installed the driver from @codahq and am confused as to how to set up commands beyond the basic single, double tap, and hold. If I try to make a rule or use ABC, these are the only options. Still new to HE so not sure if I should be doing this a different way, any help would be appreciated. Thanks in advance.

From the thread you linked to:

image

So, double-tap is the same as Button 1 being pushed to Hubitat. So, in a rule or ABC you would use button 1 pushed. Triple tap up is button 3 pushed. And so on.

2 Likes

Correct I saw that, when I make a rule other than single or double tap or hold nothing happens. When using a triple tap, which option would you use when prompted for single or double tap?

What do you mean Single and Double tap? You don't use single and double tap. For triple tap up you use button 3 pushed. Don't use the what it is the ACTION column, use what it is in the button # column.

Maybe move away from ABC and just use Rule Machine. ABC is giving you too many options. The default apps don't use doubletappable as a capability. And the drive you are using has adapted for that.

If you go into Rule Machine, pick Button device and then the switch then pick autofill for Pushed, it will fill in all of the empty boxes you can fill in for each of the 12 buttons. They all use only the pushed capability.

I meant pushed or double tapped. That’s exactly what I was doing, I tried a few rules with pushed and got nothing. Maybe reinstalling the driver will help I’ll try that when I get home

I reinstalled the driver and same results. This is what my rule looks like, am I missing something?

Okay....so you triple tapped the upper paddle and what happened? Can you turn on Logging for both the dimmer and the rule?

Nothing occurs for a triple tap,
This is what the log shows

After you his "save" on the driver did you hit "configure"? Is both descriptive text logging and debug logging turned on for the device and logging turned on for the rule?

Can you show a screenshot of the device edit page?

Yes both are on. I hit configure on the device page and it didn’t do anything as far as I can tell. I’ve been scanning various posts and found out I’m not familiar with how to check/change the driver of a device and I have a feeling this is my problem.

Strange that it is showing numberOfButtons as 2 instead of 12.

That’s what I thought, makes me think I missed a step or did something wrong

Does it show the Bedroom Dimmer is using the "HS-WD200+ Dimmer" driver and when you go to your driver code and click that driver does the change log show 1.0.3 as the last entry?

  • Changelog:
  • 1.0 2019-06-07 Initial Hubitat Version
  • 1.0.1 2019-06-08 Fixes for some hubs not liking BigDecimals passed as configurationValue
  • 1.0.2 2019-06-09 Small fix so that when setting LED colors on a fan and a dimmer 0 can be used for all as well as 8
  • 1.0.3 2019-09-12 Fixed the delay between level gets in setLevel

My apologies, new to HE and forgot to add the driver as a virtual device. Had done it once with tutorial and tried to do it from memory

Wait what? You don't add the driver as a virtual device. You have to assign the driver to this device. And your screnshot does not include the driver selection, that's what I wanted to see. Can you please show the selection for the device type in the device? You need to pick from that drop-down the driver that you loaded. Do not create a virtual device. That will not help you.

Totally confused myself with another situation, I completely overlooked that “type” is where I select the driver. Everything makes sense now I appreciate the help everyone!

1 Like

Download the Hubitat app