Exclusion issues C8

@bcopeland no idea the last time I did a exclude but never done one in the C8 because I migrated from the C7.

However I'm just not able to remove a z-wave device. I'm reluctant to force remove it and even though there is no device now next to the z-wave device it's still there and I can't remove it.

Can you post a screenshot like this of the device in question? Based on that screenshot, the ZW gurus here can hopefully recommend next steps...

not going to make a difference to this situation exclusion should work either way. I could try with a C7 but that would remove the test and wouldnt help the staff find the issue.

So an attempt to do a regular exclude just times out (with no response), or is something else happening?

yes just times out. Full stop exclusion is not working on the C8

Sorry for the perhaps obvious questions here, just trying to cover all bases... Have you tried moving the device closer to the hub?

Earlier this week, I was doing an exclude on a device out in my detached garage -- it should've worked fine (no such issues with other ZW devices out there historically), but I couldn't get that one to exclude/include until I brought it in closer. Still have no idea why that device was finicky - once paired, it's been fine since put in place out there.

[Hides behind a desk]
Are you sure that you are getting the device into exclude mode correctly?
[Ducks down a little lower]

You know we have to ask the really obvious questions first, right. :slight_smile:

What is the device - and is it mains powered? The "routing" part of the name makes me think it is a mains powered repeater/sensor, yes?

Mains powered or battery - have you tried:

  • Power cycling the device and try again
  • Power cycle hub (the old shut down-pull power-wait-power up dance) and try again
  • Liberal application of a nice stout? (To you, not the device or hub.)

Done all of this, it's not my first rodeo :joy:

It's the aeotec multi sensor 6 connected to power.

I'm doing the dance it's doing what it should just hub not doing anything. I'll need to find another device to temp join and remove but don't think I have any spare z-wave device.


So you've had two or more? :wink:

Let's pretend that @hydro311 makes me ask the basic questions, so we can blame him. :wink:

Trying another device seems like a good test...obviously you could try to remove another of your Z-Wave devices you are actually using, but I get it if you don't want to mess w/that, when things don't seem to be working at the moment. :slight_smile:


@bcopeland coul you check my logs. I have managed to manually remove it now with a lot of pain.

Using a stick i can put it in NWE and i get confirmation on the device and the software that a device gets removed. do the same for the hub and nothing it just times out. I can't join a device but again i can join it to a stick fine. So something very odd is going on.

Rebooted, down powered done loads of stuff but nothing can get it to work. Alo had a failed z-wave back up happen

@support-agent any chance of some help?

This is odd. Are other devices working as expected?

@BorrisTheCat PM me your hub id please

There is a bug that when a device is joined it might complete the joining but never gives you the UI to create the device. At 1st there is no details in the z-wave for this device, then you start seeing z-wave issue like busy messages.

If you shutdown and power cycle the hub there now will be a ghost node with no device.

If you create a virtual device as the correct device and change it's node ID to match the device will now start working however as you can see about the space/ link for the device never appears.

I get that every time I add a device using a Z Wave stick and PC Controller; the subsequent hub reboot makes the device visible to a point where I can see it in Z Wave details and click something to fix it then all is good. For me that issue (and the altered inclusion process using Z Stick) started either with the C-8 or one of the Z-Wave SDK updates just prior. What had become simple with the Z stick just became a pain.

1 Like

Yes I think something changed of you use a another stick on the C-8 but in this case I was doing the correct method and z-wave on the C-8 is just a hot mess. We are quite behind on the z-wave firmware and SDK (2022) so I have asked on another thread if there is a plan to update. Anything is better than not working at all!


@BorrisTheCat are you able to add zwave devices at all on your hub without a stick?

I migrated my C7 to a C8 Pro and since that time I cannot include any new devices. NWI packets are never broadcasted from my hub. One of my migrated devices, an older non-plus water valve, didn't successfully migrate and I now have a ghost that refuses to remove. Everytime I go through the refresh/remove dance I get the busy message. Know @jtp10181 mentioned in another thread that migrated ghosts cannot be removed. Because I cannot get Zwave inclusion working this means I cannot pair my Zstick to remove that ghost.

All other zwave devices are working fine and are very snappy.

I have PM'ed HE staff but they have been extremely slow to respond and have provided little to no help which is super frustrating. Feel like they are "ghosting" me!

I eventually was able to add one but it never joined correctly and made ghosts so long and short no. However they have found a issue that they are working on a fix for.


A migration I don't think would impact the ability to remove it. I think I may have said that migrating a ghost node to a new hub would not make it any easier to remove if it was already stuck on the original.

Hopefully the issue found will fix the handful of people who are having various outbound z-wave message issues.


Honestly, I think in some cases, even if you have a 100 z-wave devices it would be better to just start from scratch.