Everything Xbee

Looks good, you get to have something that can even run MicroPython :slight_smile:

1 Like

Have received my order, I ordered 2 USB boards and 1 Xbee, having an issue. In XCTU software it says "cannot find any radio modules". I have tried both boards? Have followed the settings at the top of this post with setting board rate, rebooted pc, updated CP210x drivers. Not sure what to do now.

I changed the Port Speed to 9600 and this found the module??? Once it was found did the config according to the first post, then change it to 115000 and it all works now???

PS love your driver for the xbees !

1 Like

For our xbee experts here, does anyone know of a setting that would cause an xbee to not transmit a ZCL response thru? all of my hue motion are constantly(daily) dropping and reconnecting. I have 5 xbees(3 XBEE3 & 2 S2C Xbees), which are most of my repeaters and suspect they are not relaying the proper response the HE hub is sending.
See this thread:

quote from the linked thread-

My ZigBee sniffing abilities are a little rough at the moment, but from what I can see the Hue Motion sends an 0x0a report and I am positing that because HE doesn't (?) send a ZCL default response back, it thinks the message hasn't got through and therefore sends the same 0x0a report as a broadcast.

This then eventually after some time leads to the device doing a leave and rejoin.

Of course I may be way off in this, as it's based on the deconz thread I linked to before and some chatter on the Hue developer forum, but it does seem to fit with the behavior I see on my Hue motions.

As mentioned my quick fix to test if it is indeed the case would be to reply to the unicast 0x0a with a ZCL default response, see if the subsequent broadcast 0x0a stops and see if the leave and rejoin behavior goes away.

Am I way off on this?

I'm no expert but
I don't think it is an Xbee issue reading through the links you posted sound like a platform issue with hue motion sensors.
I do not have any hue sensors.
What zigbee channel are you using and what wifi channel?
Could be wifi interference.
You could do a spectrum analyzer scan with an Xbee and XTCU. See how noisy your channel is.

I have also seen other zigbee devices create interference and knock devices off line.
After doing an Xbee device scan look for any devices that stand out or that you can not identify.
In my case I had an outlet device that created a second ghost device and was causing devices to get knocked off.
Only way to test is to power down one device at a time and see if it fixes the problem but the Xbee device scan might help narrow down which device.

I assume you confirmed that the hue devices are routing through the Xbee
You could also try changing the AP setting on the Xbee from 1 to 2 but I doubt that is the cause.
Also T0 should be set to 6 (extended timeout)

Thanks @NoWon. Well not only do Xiaomi devices fall off the mesh, they take a sh!t on it, before they go. Thanks to the brainiac @markus, who has been discovering all kinds of things, amongst those the Xiaomi issue.
Something about a broadcast packet , there are a few threads.

Some changes coming that should help. I have removed all but 2 Xiaomi devices, to try to get to the bottom of this. Seems only my Hue motion are affected, and I also suspect the same core issue with the "great peanut panic" saga.

PS wifi one- zigbee25=no interference, spectrum clear around 25. For the ghosts, I'm not moving from (has the auto add ghost feature-and helped greatly in solving this)

What do the xiaomi devices before dropping off that causes the issues in the mesh?

It's been awhile since I have played with Xiaomi devices but if I remember correctly they don't like channel 25-26. I found channel 20 worked much better with them.
Perhaps the same is for Hue devices.

It depends much on what is around you. I run my Xiaomi/Aqara mesh on 26... Not that I recommend that channel, just saying that it works there as well if you don't have other options.

They don't really do anything other than that they can end up sending faulty Beacon packets (1 in 80000 packets) which will cause a PAN id change and then all goes badly after that. It is more a matter of how parts in the mesh interact and how the controller react to/prevent those things from causing wide-spread issues. Complex things to do for certain.


I have encountered a curious issue, been using a Xbee as an arrival sensor plugged into my car's USB port for a couple of weeks now. Haven't been having any issues.

Just got a new C-7 hub and have migrated all my devices over. Noticed the Xbee wasn't working and brought it inside from the car. Basically went through and set it up again and rejoined it to my network and changed JV to 0.

The device only seems to want to stay connected to my zigbee mesh for the initial join, as soon as I cycle its power it fails to connect to the mesh until I set JV back to 1 and repair it. Even keeping JV set to 1, the device doesn't seem to reconnect after a power cycle (I base this on not seeing the battery event being generated every 10 seconds).

Kind of at a loss, nothing has changed except the migration to C-7 and all my other Zigbee devices seem fine. Any ideas?

I assume you changed the id to match the new hub pan id?

Yeah and even tried just leaving it set to 0. Connects once and then never again.

Same zigbee channel my old hub was using and I’ve disabled the zigbee radio on the old hub so no interference there.

You could re-enable the ZigBee on the old hub and connect the hubs with hub connect and use it that way
I have a C7 on the he way just waiting for it to show up.
What channel are you using?
Right now I have 1 C3 and 2 C5 hubs all on channel 20 with no issues (they are on different floors of the house)

Using channel 20 as well. I’ll try turning the radio back on the c-5 to see if it will stay connected there.

Are you using firmware 100A and the latest configuration files I posted?

I am not, using 1008 or 1009 I think it was and using same configuration files I used to set it up originally (Would have been whatever was in the first post before the latest version).

Maybe do a full reset and try the updated firmware and files.
Hopefully my C7 will arrives north of the wall (Canada) sometime this week and I have a spare Xbee3 to test with it.

If you set it up as a router and do a scan is it connecting directly to the hub?

1 Like

Is there a trick to doing a full reset? I'm not immediately seeing a "reset" button in the software. I applied the router settings and it was connecting directly to the hub.

Edit: Updating the firmware and applying the newest configuration profile seems to have done the trick.


right on!

regarding the reset for future reference
after reading the Xbee3 you can just select default then write which puts all the settings back to default setting.
Update should do the same thing as below for the firmware.
At the top in the tools drop down there is Xbee recovery
product family : Xb3-24
function set: Digi Xbee3 zigbee 3.0 TH
firmware version: 100A


sorry I don't recall but one of the xbee settings talks about leaving the network after ....., I set mine to never leave, no matter what. I think it's CR and this comes into play with HE handling conflicts, so set CR to zero