errorjava.lang.NullPointerException: Cannot invoke method on() on null object on line 5761 (appButtonHandler)

Hi there,

I was trying to create a rule so that if and when the hub reboots, it activates scenes per mode. In order to test it, I tried to reboot the hub, the rule fired but it didn't actually execute the action (which I'd configured to have a 10 second delay). Then, I removed the delay and rebooted the hub, didn't work.

I deleted the rule and recreated with a different name. I push the "Run Actions" button and get the error as in the subject line. I'd be happy to provide detailed screenshots if that helps.

Thanks.

Also, instead of hitting the button, I rebooted the hub. This is what I see:

That is weird... If you could provide some details / screenshots of the scenes, that may help. Another thing you could try in order to debug the issue as well is open the scene device edit page and try turning them on, which I believe is what the rule is trying to do.

1 Like

Hi,

Thank you for your response. I went into the scenes and noticed that the scene configured for "Away" wasn't actually of type "Scene Activator" but was actually a "virtual switch" type. I'm still testing things in my apartment so things aren't as polished here as they should be.

Problem solved after I changed the action to activate a valid scene - thanks for your guidance.

Best,
Rohit

2 Likes