Error Renaming Variables

Just updated my spare C-5 to the latest

My attempt to Rename Variable failed:

Here is the related log entry:

Now I cannot get into Hub Variables settings.
Every time clicking on the "Hub Variables" produces the above
"Unexpected Error" message.

I had only one string variable previously defined.
Just wanted to see how "Rename Variables" works but it failed
blocking access to "Hub Variables" settings all together.

I am glad, I ma testing all these new features and GUI on my
spare C-5

The only official fix I remember to this is restoring to a backup from prior to creating the issue.

What did you try to rename the variable to?

If you only had a single variable, you can recover from this by removing the Hub Variables setting-app. Then it should work afterwards. To do that, look at the URL on the page for Hub Variables, it will look like this:

Edit that URL (with your IP and the number yours shows instead of 25043, to this:

At the bottom of that page you can Remove Hub Variables:

Screen Shot 2022-09-23 at 9.20.36 AM

Then try running Hub Variables again from Settings.

This is a safe way to recover Hub Variables from this sort of error, unless there are Connectors. In that case, I should be contacted here by PM for assistance.

1 Like

I followed your suggestion and looks like my single variable was restored
and even accessible (this page now has a new view):

However clicking again on the "Rename Variable" button produced
exactly the same result:

@thebearmay The problem happens just by clicking on the
"Rename Variable" button.

@bravenel Second time yours suggested trick is not working anymore
(and now page ID is different


Now what?
I guess, I have to restore previous version or do you have
different suggestions?
I can wait for your instruction before doing anything which may
destroy a debugging effort.

Yes, the appId changed. But you can still remove the setting-app with that new appId. Then I suggest you remove that variable completely with the trashcan icon, rather than repeating this process.

This is exactly what I did (I actually forgot what was previous ID number).
And now I am getting 404 Page not found error message.

Open Hub Variables from Settings page. Ignore error. Edit the URL for that page as described above.

On my work horse C-7 I have tons of different variables.
Many needs to be renamed in order to better represent what they are for.
I was waiting for this "Rename Variable" feature but it looks like
I cannot use it safely. And of course, I don't want to go through process
of creating new vars and than replacing old vars with new on in very
many places. I can wait for the real fix for this issue.

1 Like

Well, l tried this even before you suggested and I am getting the same 404 Page not found error.

OK, I am sorry for the noise. It works. It did not like extra slash at the end.

So what do I do with vars on my main C-7
As I mentioned above, on C-7 I have many vars of different types.
Now I am afraid to touch this.
BTW, I did not update my C-7 to latest firmware.
C-7 still runs and looks very stable.
If I destroy it I will be killed by my lovely wife.

There is a bug with rename variable, evidently. We will get it fixed.

1 Like

Fixed in Release 2.3.3 Available - #3 by gopher.ny

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.