Error 500 on all pages

I was having issues with events not getting picked up... I started excluding the zwave devices that seemed to be malfunctioning. On the second device, it failed to exclude. all the zwave devices were imported from a C4 to a C7 about 6 months ago without issue. trigger problems started just about a month ago and I only just had time to try to address it.

I tried to exclude all zwave devices, but I had to force remove most. once that was done I tried to reset the zwave radio and got an error that the radio could not be reset. after that I tried to do an include then I got a 500 error.

I tried a soft reset and still getting 500s. tried a roll back and that put me into the "getting started wizard" which forced an update to the latest firmware.

this feels like a hardware issue, but i can't see the logs to verify.

I moved my HE to a different network port yesterday, and in doing so, I now have a corrupt database.

I've tried soft reset, but cannot restore as I am met with Error 500, when I click "Backup and Restore".

What next? Factory Reset?
Does that mean I have to re-pair all Zigbee/Z-wave devices?

If your problem persists, please perform the following steps:

  1. Go to Diagnostic Tool
  2. If you don't have the latest Diagnostic Tool (version 1.0.97) then follow these instructions to download the latest version.
  3. Perform a Soft Reset by following instructions in this document: Soft Reset | Hubitat Documentation
  4. Once the hub is back online, restore from a backup.

NOTE if the hub was unable to install the 2.3.3 platform version, and your hub is still showing that is running an older version, then go to the Diagnostic Tool and select "Download latest version". Once the download completes, click "Restore previous version" and select the latest 2.3.3 version.

1 Like

I can't seem to update this.
xx.xx/hub/cloud/updateDiagnosticTool can't be reached

Can you confirm by some browser-independent means (eg. arp + ping) that your hub is that the IP address you believe it to be?

My Unifi switch forces a fixed IP on that port and device. I don't know about ARP Ping, but I can ping that address

Does MAC address at that port match the hub’s MAC address?


My issue has been solved by downgrading one version, then restoring from a known good backup


That worked for me too, but then updating to brought back the corrupt database. I'll stick with the rollback for now.

That shouldn't be happening. Can you PM me your hub's id, I'll take a look at the engineering logs?

Were you on 2.3.2 and updated to 2.3.3? I'm guessing that the corrupt database was left over from the previous update attempt, but will have to confirm in the logs.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.