Envisalink Integration: Connection Driver: TPI Login password required

I installed the Envisalink Integration. My motion zones are not working and the device is not showing its current state. I'm getting this error..Envisalink Integration: Connection Driver: TPI Login password required. I don't exactly know what password it is looking for. I tried "user" but that didn't seem to work. I tried the 4 digit code to the alarm panel. Any suggestions?

IIRC (it has been three years since I set this up) I believe it is the Envisaslink device password that you used to set up your Envisalink device when you registered it with EyezOn. At one point, I believe it used to have to be restricted to 6 characters if you wanted it to be able to integrate with HE but that may have changed since that time with any upgrades to the Envisalink Integration app.

I spoke with Eyezon support. The default password for the Envisalink 4 is "user".

1 Like

I did set the correct password. The TPI login error is gone but my alarm is still not connected to Hubitat. My motion sensors don't show as active. Any suggestions?

Perhaps a silly question but did you add them into the EyesOn app first, then download them into the Hubitat Envisalink Integration app (each device or β€œzone” will show up as a child device under your Envisalink device name).

They have been in my EyesOn app for years. I ended up trying it at another location that I use HE. It worked fine with that Envisalink. So I just deleted the app, app code, and driver code and started over again from scratch. It is working fine now. Thanks.

Glad to hear it worked out. It has been so long since I set up my integration that I have forgotten half of what I did, LOL. Anyway, happy for you!

hey guys i been driving myself crazy with this same thing anyhelp would be appreciate i havedeleted everything started over countless times whole reason i got this hubitat an this evislink was to try o make my own setup i have worked in security as a service tech for years and i gota say im lost man....

where do you delete these codes i have deleted everything and factory reset still the same result tried the originall password user i am beyond frustrated.

my envisilink works great hubitat not so much with this situtation has me rething hubitat all together

Is the Envisalink app up on your Hubitat? If so, did you add your zones?

i have it on there its just not responding to hsm at all says its online but in the logs i am getting tpi login requires password i have tried every password since i set up the envisalink all the ipdresses installed uninstalled tons of times even wiped my hubitate completely and deleted my envisalink from there site and factory reset it same thing ugg i am regretting getting these 2 been fighting this for 2 weeks divig myself nuts lol

i filled out the zones they didnt auto populate

the envisilink4 works fine on its own

and the hsm dont seem to link to the envisalink

Do you know the IP address of the envisalink on your network?
Did you set the password as user and the master code to the code that is used to disarm the alarm (not the installers code)?

Is anything showing up under Current State when you look up the device for the alarm?

curent state says online nothing elese i set password to user and the code to master of alarm

Do you know the ip address of the envisalink?

yes what it says on their site and my router