Envisalink Help

Hello, i Installed Envisalink code and when i attempt to add zones i get this message
Error: Cannot invoke method getChildDevices() on null object
when i look at the log this is what i see
java.lang.NullPointerException: Cannot invoke method getChildDevices() on null object on line 266 (zoneMapsPage)

i can log into the envisalink TPI just fine from a browser. Is this an envisalink issue? they are on the same network also

From the looks of it, that is not my latest version as the line number doesn't make any sense. What version are you using? Maybe you installed Cuboy's?

Have you installed the Connection Driver?

From the sound of it, you're on on older version. Around the point where this exception occurred it's trying to pull in the Envisalink device by the Id, this suggests to me that the device did not get installed as expected and likely points to you have not installed the Connection Driver.

Hi Doug

thanks for the reply, i originally installed cuboys. it has 2 drivers to install. i was having trouble with it and when i was ready peoples comments i came across yours. i uninstalled his and installed your connection driver and app. i really thought it was the latest one. i will check when i get home

I'd be concerned having both drivers of the different implementations on the same system. Cuboy and I worked together until the point he desired a different direction for Dashboard integration than did I. His fork included a button based implementation for Dashboards, I chose to forgoing the button implementation instead preferring to integrate with HSM. Choose whichever suits your needs.

My suggestion would be to uninstall all Envisalink Apps and Drivers, and delete the code. Then, using the Import feature on the drivers/apps IDE, pull in my latest releases.

i deleted app and deleted both the application and the driver. rebooted hub. installed the code from your github link and the same error is happening. is it possible some code stayed in when i installed cuboys the other day? Im still new to hubitat i was a smart things user so im sorry for all the questions

this is the log
search

app:652019-02-26 07:33:57.033 pm errorjava.lang.NullPointerException: Cannot invoke method getChildDevices() on null object on line 266 (zoneMapsPage)

app:652019-02-26 07:33:56.929 pm debugEnvisalink Integration: Showing zoneMapsPage

app:652019-02-26 07:33:54.747 pm debugEnvisalink Integration: Showing mainPage

app:652019-02-26 07:33:52.207 pm infosubscribing

app:652019-02-26 07:33:52.179 pm infoinitialize

app:652019-02-26 07:33:52.177 pm infoupdated

app:652019-02-26 07:33:50.738 pm debugEnvisalink Integration: Showing mainPage

app:652019-02-26 07:33:47.411 pm debugEnvisalink Integration: Showing mainPage

app:652019-02-26 07:33:42.258 pm infosubscribing

app:652019-02-26 07:33:42.231 pm infoinitialize

app:652019-02-26 07:33:40.375 pm debugEnvisalink Integration: Clearing State Variables just in case.

Ah ya, my bad. That is the 0.3.1 release. I've never encountered this problem.

Do you have an Envisalink device in your device list?

When you are in the app, click the gear at the top right (next to the question mark).
From the app Status page, scroll down to the Application State section and look for EnvisalinkDNI. What's the value listed there?

If you found an installed Envisalink device in your device list, does the value match the Device Network Id of the Envisalink device?

i do now lol. wow now it is starting to make sense. im truly 3 days in with hubitat. so when i try to go into zones i still get this error and new errors when i try to arm in the device it gives the below errors. below that is what i see in the app status page. thanks for all your help
dev:332019-02-27 11:47:34.832 am errorjava.lang.NullPointerException: Cannot invoke method ifDebug() on null object on line 447 (ArmAway)

dev:332019-02-27 11:46:40.187 am errorjava.lang.NullPointerException: Cannot invoke method ifDebug() on null object on line 447 (ArmAway)

app:652019-02-27 11:46:29.971 am errorjava.lang.NullPointerException: Cannot invoke method getChildDevices() on null object on line 266 (zoneMapsPage)

Application State

Name Value

creatingZone false
enableHSM true
EnvisalinkCode
EnvisalinkDeviceName
envisalinkIntegrationInstalled true
EnvisalinkIP
EnvisalinkPassword
isDebug true
version 0.3.0
Scheduled Jobs

No Scheduled Jobs are set.

Ok, now the ifDebug error I've heard but not experienced.
Until such time that I get this error resolved, you may revert to using 0.2.1, which has been reported to work without this error.

Sorry for the inconvenience.

One other observation, you don't seem to have an EnvisalinkCode or IP Value or DeviceName??
Did you enter these into the application during installation?

Also, I forgot to increment the version value. You actually have 0.3.1 currently installed. I do have a 0.3.2 version out there as of, I think, yesterday (all days are blurring together as my IRL job is reaching peak before delivery, damnable waterfall BS, deadlines != effort, and clueless execs... anyway...).

I don't think, however, 0.3.2 addresses the problem you're encountering, rather it was for a new feature.

thank you sir, yes i did input name and value. i will tinker with the upgrade to 3.2 and or downgrade to 2.1

let you know
thanks again

same errors on the upgrade to 3.2 about to downgrade

2.1 works perfect. looks different but works perfect. i got the HSM set up and working.
i have a brand new c5 hub is this possibly why the new code does not work?

I'm not sure yet, but I doubt it's the hardware. The firmware for both devices should be the same. Works fine on a system already setup as far as I can tell as I'm using it without problem, so you maybe able to use 0.2.1 to install and setup and then upgrade without trouble. I'll be looking into a bit deeper today, I hope to have a fix soon.

Thank you Doug

OOOOH, I'm an idiot. I found the problem. I'll have a fix out as soon as I can.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.