Enphase monitor interferes with Z-Wave

"The z-wave tag cannot be used in the Help category?" ok lol

I’m not really asking for help, rather describing something I just discovered because I found it fascinating. Maybe there’s an elegant solution to be had, too.

UPDATE: I may have been too hasty in my assessment. I am still having issues with the wall switch and remote in my room, even though I've completely disconnected the Envoy. I thought I had tested it sufficiently when I first discovered the issue, but I guess not.


The Enphase Envoy Communications Gateway[1] causes significant interference with Z-Wave.

Longer Explanation

I have a C8 hub and several Z-Wave devices throughout my old (1926), but renovated house. Generally things work well, but sometimes a button press just takes aaages to make its way to a light turning on or off. And it seemed to be worse at night. But recently it has gotten much worse, to the point where trying to turn on the light to my bedroom from the wall panel just didn't work (but asking Siri to do it always worked).

I didn't want to take the time to troubleshoot it. But the observation that it was worse at night kept nagging at me. The only thing I could think of was the solar panels on the roof don’t produce at night, and the only part of that system still powered on at night is the Envoy Communications Gateway, which is plugged into the same branch circuit as my Hub, and on the shelf below it.

So I tried the experiment: verify the light switch buttons weren’t working, unplug the Envoy, try the switches…they worked perfectly! Plug the Envoy back in, try the switches…fail.

The Envoy uses powerline signaling to communicate with the microinverters. All I can imagine is when it can’t find any, it yells on the powerline looking for them.

I’m going to try moving it further away from the hub, or plugging it into a different branch circuit, to see if that improves anything.

I think the Z-Wave button device (a Zooz 700 Series Z-Wave Plus Mesh Network Scene Controller) was susceptible (and to a lesser extend, the Aeotec NanoMote Quad), because the Switch device that actually controlled the lights always responded to Siri.

  1. I can't find a product page on Enphase’s site (a huge red flag), but here’s a reseller: Enphase Envoy - Communications Gateway with WIFI Adapter - Enphase ENV-120 M ↩︎

Try a Ferrite ring core on the Hubitat power supply cord. It's a solid maybe and a really inexpensive solution. Theses solved the Hue led light interference with my garage door opener. https://www.amazon.com/gp/product/B09WMZ2NFC/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&th=1

Yeah, it already has one (came with it).

It was a thought. My C8 does not have one.

It's a good thought. And I misread! My Envoy gateway has one, but not my C8.

Sure glad my new system is speced with Hoymiles.
It uses 2.4 GHz so it should probably play nice with ZB; none of my other WiFi stuff has ever bothered it - yet :wink:

Seems I was wrong about the Envoy being the cause of my problems. They reappeared even though it was disconnected.