Enable child device for use with hub mesh

I have recently purchased a c8 pro and repurpose my c8 for upstairs zwave. I have enabled hub mesh on both devices and went to share a aeotec dual nano switch from the c8 upstairs with the c8pro downstairs but the child devices show as disabled and I can only control the parent from the c8pro. Might there be a way to control child devices using hub mesh? I have tried enabling device but it just goes back to disabled state and the child device is fully functional on the sharing c8 hub located upstairs.

@gopher.ny tagging you on this. I noticed the same thing as I was setting up a new C8 Pro recently. This happened on all of my devices that have child component devices so it’s not specific to a specific driver.

Using browser development tools I see the hub mesh toggle on the child devices is off/false and obviously hidden so this cannot be corrected. I even turned off hub mesh on the parent device and back on and that didn’t correct the issue.

I ended up using PostMan to fix the problem but forgot to report this issue to you.

By way of trying to understand the issue a little more, well others understanding the issue.... Have you tried sharing a device without children, as a comparison?

After rebooting both hubs the hub mesh did not initialise. When I checked the hub mesh settings I found that the c8 was asking for a token to be entered from the pro model. I then went to the pro model and into the hub mesh setting and generated a token to which I copied and paste into the normal c8 hub under hub mesh setting and then the child devices showed online. Oddly I only have to enter token one way ( didn’t have to enter one token in each hub) even though traffic is two way.
Seem to be Working as expected now, thanks