Elusive Z-Wave Issues - Out of Ideas

This sounds very similar to my issues. I have an Inovelli switch that is about 10ft from my hub, one wall in between, 100kbps, but often becomes unresponsive and has high reroutes (4 so far). After a few seconds, it realizes the route it temporarily had was junk, switches back to direct and boom it's instantaneous again (2ms RTT)

There are 9 switches being turned on or off (depending on time of day), 4 dimmers turned on and set to a particular level on the button control I run to test the issue.

I've been eyeballing this warranty voiding project... my solder-foo is just okay so am a bit reluctant to tackle but it doesn't look that complicated really.

Not suggesting you should do anything like this (or even have to) but I believe of those brave souls who have taken on the challenge ?most? have seen improvements at least in terms of direct device connections and fewer route hops..


Make sure these have the latest firmware installed. When they were first released their was a bug where they would flood the network with battery reports. Like every few seconds. They fixed it via a firmware.

On my ZSE41 and ZSE42 I updated them to v1.20.

And the Zooz 4 in 1 is not compatible with the C7. I don't think you have any of those. They will cause zwave to just hang. I found out the hard way.

If they are the V2 (500 or 700) and configured properly, no issues here, I have 4 going on a C7.

1 Like

Your one of the lucky ones. Their are threads on the forum explaining the issue with s0 and the c7. I bought the v2 (700) last week and didn't think to look it up first. Can't add it without s0. It was causing random other issues. I just pulled it off and everything was back to normal. I wasn't going to even bother to apply the work around of using a secondary controller that is also mentioned in the zooz support articles.

Just mentioning it at this point as any little thing can help troubleshoot this problem.

It must be a 500 series then, because the 700 series would pair with S2 or None if you press skip, there is no S0 option on the 700 series. I have a 700 series paired with S2 for testing and it works fine. My most heavily use V2-500 is paired S0 and works unless I am testing things and spam it will commands. The other 2 are 500 series and paired without security. I also use my own custom driver which I posted on here, not sure if that is helping any but it does add extra configuration options.


Same here, I have a ZooZ 4in1 500 series and it works fine. Paired with no security on a C7

Meme Reaction GIF by Robert E Blackmon

Ya was the 500. Thought I got the 700 but was sent the 500. It doesn't help that the name is all the same. That explains my issues though. Its now sitting in its box again.

My 4-in-1 700 has 700 Series in big red letters on it. If you were sent the wrong ones I would send them back

1 Like

Check! I made sure all were updated to the 1.3 firmware. That is the latest as of last week when I checked with Zooz support.

If you can do w/out your hub for a few days, @lewis.heidrick will do the mod for you for parts + shipping (and I would certainly include a tip). :slight_smile: The next time wife and I are on vacation together I'm going to send my hub to him to do the mod. In the meantime I've mounted my hub vertically on the wall which should for my use (single story ranch style home) improve my hub's signal orientation.

Per this post...

1 Like

He really is one of the good ones... :wink:

However I prefer to destroy my own devices myself thank you very much! Doing so also allows me to buy tools I will rarely use like a new soldering station (based on prior recommendations of this "keeping up with the Jones's" community). Why deny me this?


While waiting for the Antenna to arrive, I too purchased a new soldering iron, expecting to use it on this mod. I ended up using my older one because the new one was taking too long to charge the first time. :smiley:

I'm talking about 3 mins is too long. :smiley:


Wow, what kind of iron is it? Mine heats up in about 3 seconds.

If you don't buy at least $300 worth of tools to complete a $30 project, the project was definitely not worthwhile.


This one heats up in under a minute. Been pretty happy with it. It's a cheap one but works well.

1 Like

I like that it has a dial. Quick to switch temps without looking with that style.

it was brand new and didn't have a full charge when I pulled it from the package. I plugged it in to charge but was ready to remove the internal antenna before it was charged enough to use. :smiley:

I got the antenna and the soldering iron on the same day.

1 Like