Elevation 2.0.1 can't choose a different dashboard

I am using the new Hubitat Elevation 2.0.1 on Macos (Edit: I meant IOS). When I first open the application and go to the Dashboards tab I can choose a dashboard. But once I choose a dashboard I can not switch to a new dashboard.

On the old app, clicking on the Dashboards Icon would go back to the Dashboards menu so I could choose a new dashboard. That does not work in the new app. Switching to home then back to Dashboards returns me to the dashboard that I selected.

Is there a way to select the dashboard I want besides closing the application and re-opening?

If you open an original Hubitat Dashboard, simply click the small Hubitat logo in the top left corner of the dashboard. If one of the new EZ dashboards, click the left arrow on the bottom left section of the dashboard.

I have the same issue. Clicking on the logo does nothing.

I am running the latest Beta version 2.0.2 (284) on my iPhone running iOS 17.5.1. I tested the above before posting.

@user3348 - You mentioned using MacOS. Can you test on an iPhone or iPad to see if the problem is specific to running an iOS app on MacOS or not?

@j715 - Are you using iOS, MacOS, or Android?

I have tried it on both my iPhone and my iPad. Same result.

You might need to enable this checkbox on the dashboard’s settings page from within the hub web UI:

If you don’t see it, try tapping “advanced” first to expand the sub-menu.

1 Like

Yes that works. Problem with that. If I have a link to a particular dashboard only for someone else then they will be able to get to any dashboards. Not good.

In the old HE app you could click on the dashboard at the bottom of the screen and it would go back to the dashboard menu. Which the new one should do also.

1 Like

Yes I’m hoping that feature is restored too.

1 Like

Oops my mistake. I meant IOS not Macos.

All of my dashboards have the Allow Logo Click enabled. All of them are the old dashboards.

My dashboards do not have the logo in the upper left corner. I tried clicking in the upper left corner just in case and that did not work.

More details:
Phone is running IOS 17.5.1
Hubitat is a C7 running Version 2.3.9.135. Updated to 2.3.9.158 but behavior persists.