Editing anomaly in RM5

@bravenel I am moving my shade rules from legacy to RM5 to switch to Hub variables.

The rule listed below is pretty much an exact duplicate of the legacy rule. For some reason it has added the area highlighted in black to the top level view of the rule. I wondered why it did that? It doesn't really seem helpful.
These are virtual shades that when changed trigger the actual shades controlled by a Bond Hub.

That looks like a UI bug. I will investigate. Clearly, those should not be there (although probably harmless).


Another issue I ran into with shades. I can't set the shade position of my Virtual shades to 0. I can in RM legacy but not in RM5. In the screenshot below you can see it says you can enter a value between 0-100, If you enter 0 you never get a done with action button. You do in RM legacy, and 0 should be a valid input for position on a shade.

As a workaround since you can use a variable now, I went that route.

@bravenel Another issue with a fairly simple rule. The first screenshot shows the rule, and the second the error that is occurring. This is again a rule that is a duplicate of a RM legacy rule, now using Hub variables instead of global variables.

The rule has no triggers it is initiated by another rule. Every time I click run actions, I get the error. OFPosition is the Hub Variable. I pass it to a local variable in the rule and use the local for conditions. I do this because I have this same rule for each shade. I can then clone and only have to make minor updates for each shade. The ELSE IF seems to be the hangup, I don't see a problem with it.

Just changed it to three IF statements and I get the same error at the same place.

{EDIT 3}
Apparently it is just setting a shade position that causes problems. The simple rule below generates almost the exact same error.

If I remove the shade position settings from the original rule it no longer generates an error.

I would suggest that you leave this in Rule-4.1 until the bug with Position Shade is repaired in 2.2.9.

Release is out and fixes this UI break for Position Shade.

Everything seems good except, I still can't enter a 0 for shade position in the UI. I can use a shade position variable set to 0 so it's not a huge deal.

Thanks for the fix. All my rules seem to working as before.

Sorry, missed that. Lower Shade will do the trick also, leaves the shade at position 0.

I don't suppose you could figure out why whenever you say raise or lower one of the virtual shades to an Alexa device it will raise or lower the shade up or down 25%, but it always says I am not quite sure what went wrong. It works fine, but it always gives you that message.

Right now I have Alexa routines that change the position, so I don't get that message. If not for those message I would not need Alexa routines at all.