Ecolink Sensors

I have the Zwave Ecolink water sensor and also for something else a contact sensor. I have tried to exclude and include and neither has included in the hub.

It would help if you could go into more detail to narrow down why you’re having trouble.

What steps are you taking to pair the devices?

Do you see anything in the Hubitat logs?

What, if anything, do indicator lights on the devices do while you’re attempting to pair? For example, color and pattern of flashes.

1 Like

As per the Hubitat documentation, I started the exclusion removed the battery for 10 seconds reinserted the battery. The light which is red on the water sensor was steady. I then did the same for inclusion. It counted down to 0 from 100 and the light stayed steady. The same for the contact sensor except the light is green. I tried them both several times with no success. Nothing ever flashed. I checked the batteries and both were good.

What about the documentation that came with the devices?

Typically there’s a button or pinhole that when held or pushed in a specified pattern will put the device into pairing and/or exclusion mode.

1 Like

Is these your devices?

When I have paired these, I remove the battery first, then put the hub in inclusion mode, then re-insert the battery. I have the contact sensors and it looks like the water sensor is almost the same device. Have a window or tab open to your logfiles because that is where you will see if something happens (or not).


Also be close to hub then.move to install.location

1 Like

Just got them to work. I don't know why but when I kind of in/out with battery it started to flash so I included an it work. So I did for the other one and the same. Now they work.

1 Like


1 Like

@mrcorvettegolfer Don't forget to check your zwave details page for any ghosts that may have been created during your attempts to include these devices. It's a lot easier to get rid of them sooner rather than later.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.