Echo Speaks Hell

OK. I guess I really really don't understand how this works.

For days I've seen that there is an update to Echo Speaks. I had and now is out. I tried updating it several times. Tried a repair. Always get this in the log.

Echo (v4.1.9.9) | CODE UPDATE required to RESUME operation. No Device Events will updated.
I use a lot of notifications and really didn't want to start over, but kept hitting a wall. So I did the nuclear option and deleted the app and started again. But got a duplicate. So I deleted the old one. Went into HEROKU and manually deleted the server instance. Installed again. AND I'm back where I started.

Really feel like an idiot. What do I do next? Current state:


Sorry, but this app doesn't make sense to me and the documentation doesn't either. I get that it is immensely complex and it's free, but I seem to get into this bind every few months.

Anyway - next steps please? Kinda at the end of my rope here.
Jay W

1 Like

Which part are you having trouble with? Did you install it through HPM?

1 Like

Echo Speaks is composed of 2 or 3 apps (in Apps Code) and 2 or 3 Device Drivers (in Drivers Code). Did you ensure all of them were up to date (and not duplicated)?


This issue has been fixed as of last night. There was a minor issue with the Echo Speaks - Actions module that caused the upgrade to failed. Run it again and it will work now :+1:

I have had it running for a couple of years. Yes, installed through HPM. Was installing update, but the Echo Speaks device wouldn't install because of a code error. So now the code is out of sync. A delete and fresh install didn't work. An HPM "update" didn't work. So, I'm dead in the water until the code is fixed and committed to the repository. I believe that describes where I'm at. If anyone knows a way to work around this, I'm all ears. Until then, I have to wait for the bug to be fixed so I can reinstall.

Are you sure? The version hasn't changed.

Tony remerged and republished the code, version is still but now works.


SUCCESS! The HPM Update succeeded. Went to the Echo Speaks App and clicked Done. Everything is back operational. Thanks to you and Tony. Now I want to never update this app again. :slight_smile: