Echo skill errors

Within a couple hours of my update to (C7) I started seeing lots of errors coming from the Echo skill. While I do have many rules that use Echo none of them are sending that much stuff, especially overnight. I also run Echo Speaks. Oddly enough both the skill and echo speaks seem to be working fine.

Correlation is not causation of course, but....

Any suggestions other than a downgrade?

I see occasional errors in triggering background jobs, which happen ~2 seconds before these Alexa errors appear. Usually, those are transparently recoverable, but could you please try taking a backup, doing a soft reset, and immediate restore? I want to be sure things don't occasionally try to fire twice. And yeah, if they run fine the first time around, attempting to run the same command a second or two later would cause throttling, so symptoms match.

Did a backup, soft reset, and restore. Still seeing the same errors. I did see a post from back in '19 with someone with the same issue, and he resolved it by uninstalling and reinstalling the Amazon skill... dunno if that's a thing or not. I would prefer not to rebuild my routines in Alexa but I will if I have to.

@gopher.ny In the mean time I realized that one of my Echo zones from Echo Speaks was being shared via hub mesh, so I disabled hub mesh on that device. My two hubs were not on the same software rev anyway so it was disabled on the receiving hub side. I also did a refresh of devices in the echo skill and let it push the devices to echo just to eliminate that as a possibility. None of that worked, but then I noticed my Alexa phone app wasn't working. So I decided it was time for a purge. I completely disabled the echo skill on the alexa side, deleted the app on the HE side, and then went through and deleted every device Alexa saw. I had all sorts of crap out there including duplicate devices, so probably better to just start from scratch. I reinstalled everything and sure enough the errors came right back.

1 Like

I'm seeing a ton of activity from Echo Speaks. Could this be what's generating the transactions that are causing the echo skill app errors?

Saw something new in the logs today while I was removing devices from the echo skill app on the HE side... not sure if this helps at all @gopher.ny but figured I would pass it along.

@gopher.ny I tried loading the echo skill app on a nonprod HE, then using hub mesh to link to the production device drivers. As soon as I configured the echo skill app on the nonprod hub the errors started appearing. There's really not much running on the nonprod hub at all, which leads me to think it is not some other misbehaving something or other causing issues and that it must be more of a core problem.

Anything else you need from me? Should I open a ticket with support or do you have it?

I see the errors disappeared after a reboot, but I'll check it out for a root cause.

Edit: Ok, it didn't have a network address that it could detect, and other network calls were erroring out too. I understand what happened but now how it got there, at least not yet. It definitely can happen only during a reboot, the network address is cached even if connection drops.

I'm not sure I understand your reply. From what I see in the logs the errors themselves continue to be generated every few minutes even after several reboots. It also happened on two different HEs, connected to two different mesh nodes. Or perhaps you're referencing something I can't see in the logs that may be the underlying issue?